]> git.pld-linux.org Git - packages/kodi-addon-inputstream-adaptive.git/blob - kodi-addon-inputstream-adaptive.spec
up to 20.3.5
[packages/kodi-addon-inputstream-adaptive.git] / kodi-addon-inputstream-adaptive.spec
1 # TODO:
2 # - package Bento4 and use system one
3
4 %define         kodi_ver        20
5 %define         next_kodi_ver   %(echo $((%{kodi_ver}+1)))
6 %define         codename        Nexus
7 %define         addon           inputstream.adaptive
8
9 %define         bento4_ver      1.6.0-639-6-Nexus
10
11 Summary:        Kodi InputStream addon for several manifest types
12 Name:           kodi-addon-inputstream-adaptive
13 Version:        %{kodi_ver}.3.5
14 Release:        1
15 License:        GPL v2+
16 Group:          Applications/Multimedia
17 Source0:        https://github.com/xbmc/inputstream.adaptive/archive/%{version}-%{codename}/%{version}-%{codename}.tar.gz
18 # Source0-md5:  88a6fff88504aa0e3d83ba28cb6ac420
19 Source1:        https://github.com/xbmc/Bento4/archive/%{bento4_ver}/Bento4-%{bento4_ver}.tar.gz
20 # Source1-md5:  4322bd0076bf1fde49b389e73b821efa
21 Patch0:         bento4-hash.patch
22 URL:            https://github.com/xbmc/inputstream.adaptive
23 BuildRequires:  cmake >= 3.10
24 BuildRequires:  expat-devel
25 BuildRequires:  kodi-devel >= %{kodi_ver}
26 BuildRequires:  kodi-devel < %{next_kodi_ver}
27 BuildRequires:  libstdc++-devel >= 6:7
28 BuildRequires:  rpmbuild(macros) >= 1.605
29 Requires:       kodi >= %{kodi_ver}
30 Requires:       kodi < %{next_kodi_ver}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Kodi InputStream addon for several manifest types
35
36 %prep
37 %setup -q -n %{addon}-%{version}-%{codename}
38 %patch0 -p1
39
40 install -d build/download
41 cp -p %{SOURCE1} build/download/%{bento4_ver}.tar.gz
42
43 %build
44 %cmake -B build \
45         -DBUILD_TESTING:BOOL=OFF \
46         -DENABLE_INTERNAL_BENTO4:BOOL=ON
47 %{__make} -C build
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 %{__make} -C build install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %dir %{_libdir}/kodi/addons/%{addon}
60 %attr(755,root,root) %{_libdir}/kodi/addons/%{addon}/%{addon}.so.%{version}
61 %attr(755,root,root) %{_libdir}/kodi/addons/%{addon}/libssd_wv.so
62 %dir %{_datadir}/kodi/addons/%{addon}
63 %{_datadir}/kodi/addons/%{addon}/addon.xml
64 %{_datadir}/kodi/addons/%{addon}/changelog.txt
65 %{_datadir}/kodi/addons/%{addon}/fanart.jpg
66 %{_datadir}/kodi/addons/%{addon}/icon.png
67 %{_datadir}/kodi/addons/%{addon}/resources
This page took 0.078886 seconds and 3 git commands to generate.