]> git.pld-linux.org Git - packages/kodi-addon-inputstream-adaptive.git/blob - kodi-addon-inputstream-adaptive.spec
up to 20.3.7
[packages/kodi-addon-inputstream-adaptive.git] / kodi-addon-inputstream-adaptive.spec
1 # TODO:
2 # - package Bento4 and use system one
3
4 %define         kodi_ver        20
5 %define         next_kodi_ver   %(echo $((%{kodi_ver}+1)))
6 %define         codename        Nexus
7 %define         addon           inputstream.adaptive
8
9 %define         bento4_ver      1.6.0-639-7-Omega
10
11 Summary:        Kodi InputStream addon for several manifest types
12 Name:           kodi-addon-inputstream-adaptive
13 Version:        %{kodi_ver}.3.7
14 Release:        1
15 License:        GPL v2+
16 Group:          Applications/Multimedia
17 Source0:        https://github.com/xbmc/inputstream.adaptive/archive/%{version}-%{codename}/%{version}-%{codename}.tar.gz
18 # Source0-md5:  ebdd8b3582912ac11eacc5b7df84b9f3
19 Source1:        https://github.com/xbmc/Bento4/archive/%{bento4_ver}/Bento4-%{bento4_ver}.tar.gz
20 # Source1-md5:  5532a65b8da2e051b70de761ee84141d
21 Patch0:         bento4-hash.patch
22 Patch1:         gcc13.patch
23 URL:            https://github.com/xbmc/inputstream.adaptive
24 BuildRequires:  cmake >= 3.10
25 BuildRequires:  expat-devel
26 BuildRequires:  kodi-devel >= %{kodi_ver}
27 BuildRequires:  kodi-devel < %{next_kodi_ver}
28 BuildRequires:  libstdc++-devel >= 6:7
29 BuildRequires:  rpmbuild(macros) >= 1.605
30 Requires:       kodi >= %{kodi_ver}
31 Requires:       kodi < %{next_kodi_ver}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Kodi InputStream addon for several manifest types
36
37 %prep
38 %setup -q -n %{addon}-%{version}-%{codename}
39 %patch0 -p1
40 %patch1 -p1
41
42 install -d build/download
43 cp -p %{SOURCE1} build/download/%{bento4_ver}.tar.gz
44
45 %build
46 %cmake -B build \
47         -DBUILD_TESTING:BOOL=OFF \
48         -DENABLE_INTERNAL_BENTO4:BOOL=ON
49 %{__make} -C build
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 %{__make} -C build install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %dir %{_libdir}/kodi/addons/%{addon}
62 %attr(755,root,root) %{_libdir}/kodi/addons/%{addon}/%{addon}.so.%{version}
63 %attr(755,root,root) %{_libdir}/kodi/addons/%{addon}/libssd_wv.so
64 %dir %{_datadir}/kodi/addons/%{addon}
65 %{_datadir}/kodi/addons/%{addon}/addon.xml
66 %{_datadir}/kodi/addons/%{addon}/changelog.txt
67 %{_datadir}/kodi/addons/%{addon}/fanart.jpg
68 %{_datadir}/kodi/addons/%{addon}/icon.png
69 %{_datadir}/kodi/addons/%{addon}/resources
This page took 0.102577 seconds and 3 git commands to generate.