]> git.pld-linux.org Git - packages/kirigami-addons.git/blob - kirigami-addons.spec
96ce486411d735fc16210921054d42b2cb585ea8
[packages/kirigami-addons.git] / kirigami-addons.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 #
5 # TODO:
6 # - runtime Requires if any
7
8 %define         qtver           5.15.2
9 %define         kfname          kirigami-addons
10 Summary:        Kirigami addons library
11 Name:           kirigami-addons
12 Version:        0.8.0
13 Release:        1
14 License:        GPL v2+/LGPL v2.1+
15 Group:          X11/Libraries
16 Source0:        https://download.kde.org/stable/kirigami-addons/%{name}-%{version}.tar.xz
17 # Source0-md5:  aeb0cf47a1915cc38444d3996c02d0d1
18 URL:            http://www.kde.org/
19 BuildRequires:  Qt5Core-devel >= %{qtver}
20 BuildRequires:  Qt5Gui-devel >= %{qtver}
21 BuildRequires:  Qt5Network-devel >= %{qtver}
22 BuildRequires:  Qt5Quick-controls2-devel >= %{qtver}
23 BuildRequires:  Qt5Test-devel >= %{qtver}
24 BuildRequires:  catdoc
25 BuildRequires:  cmake >= 2.8.12
26 BuildRequires:  kf5-extra-cmake-modules >= 5.102.0
27 BuildRequires:  kf5-kirigami2-devel >= 5.102.0
28 BuildRequires:  ninja
29 BuildRequires:  qt5-build >= %{qtver}
30 BuildRequires:  rpmbuild(macros) >= 1.164
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  xz
33 Requires:       kf5-dirs
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Kirigami-addons library.
38
39 %package devel
40 Summary:        Header files for %{name} development
41 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{name}
42 Group:          X11/Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44
45 %description devel
46 Header files for %{name} development.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe dla programistów używających %{name}.
50
51 %prep
52 %setup -q
53
54 %build
55 install -d build
56 cd build
57 %cmake -G Ninja \
58         %{!?with_tests:-DBUILD_TESTING=OFF} \
59         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
60         ..
61 %ninja_build
62
63 %if %{with tests}
64 ctest
65 %endif
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 %ninja_install -C build
70
71 %find_lang %{name}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files -f %{name}.lang
77 %defattr(644,root,root,755)
78 %{_libdir}/qt5/qml/org/kde/kirigamiaddons
79
80 %files devel
81 %defattr(644,root,root,755)
82 %{_libdir}/cmake/KF5KirigamiAddons
This page took 0.048199 seconds and 2 git commands to generate.