]> git.pld-linux.org Git - packages/kf6-kholidays.git/blob - kf6-kholidays.spec
- updated to 6.0.0
[packages/kf6-kholidays.git] / kf6-kholidays.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 # TODO:
5 # - runtime Requires if any
6 %define         kdeframever     6.0
7 %define         qtver           5.15.2
8 %define         kfname          kholidays
9
10 Summary:        kholidays
11 Name:           kf6-%{kfname}
12 Version:        6.0.0
13 Release:        1
14 License:        GPL v2+/LGPL v2.1+
15 Group:          X11/Libraries
16 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
17 # Source0-md5:  10b15c95f371c54f21e4cc49a305b9f6
18 URL:            http://www.kde.org/
19 BuildRequires:  Qt6Core-devel >= %{qtver}
20 BuildRequires:  Qt6Test-devel >= %{qtver}
21 BuildRequires:  bzip2-devel
22 BuildRequires:  cmake >= 3.16
23 BuildRequires:  kf6-extra-cmake-modules >= %{version}
24 BuildRequires:  ninja
25 BuildRequires:  rpmbuild(macros) >= 1.164
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 BuildRequires:  xz-devel
29 BuildRequires:  zlib-devel
30 Requires:       kf6-dirs
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         qt6dir          %{_libdir}/qt6
34
35 %description
36 kholidays.
37
38 %package devel
39 Summary:        Header files for %{kfname} development
40 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
41 Group:          X11/Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 Header files for %{kfname} development.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe dla programistów używających %{kfname}.
49
50 %prep
51 %setup -q -n %{kfname}-%{version}
52
53 %build
54 %cmake -B build \
55         -G Ninja \
56         %{!?with_tests:-DBUILD_TESTING=OFF} \
57         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
58
59 %ninja_build -C build
60
61 %if %{with tests}
62 %ninja_build -C build test
63 %endif
64
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 %ninja_install -C build
69
70 %find_lang %{kfname}6_qt --with-qm --all-name --with-kde
71
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post -p /sbin/ldconfig
77 %postun -p /sbin/ldconfig
78
79 %files -f %{kfname}6_qt.lang
80 %defattr(644,root,root,755)
81 %{_libdir}/libKF6Holidays.so.6
82 %attr(755,root,root) %{_libdir}/libKF6Holidays.so.*.*
83 %dir %{_libdir}/qt6/qml/org/kde/kholidays
84 %attr(755,root,root) %{_libdir}/qt6/qml/org/kde/kholidays/libkholidaysdeclarativeplugin.so
85 %{_libdir}/qt6/qml/org/kde/kholidays/qmldir
86 %{_datadir}/qlogging-categories6/kholidays.categories
87 %{_libdir}/qt6/qml/org/kde/kholidays/kde-qmlmodule.version
88 %{_libdir}/qt6/qml/org/kde/kholidays/kholidaysdeclarativeplugin.qmltypes
89
90
91 %files devel
92 %defattr(644,root,root,755)
93 %{_includedir}/KF6/KHolidays
94 %{_libdir}/cmake/KF6Holidays
95 %{_libdir}/libKF6Holidays.so
This page took 0.192607 seconds and 3 git commands to generate.