]> git.pld-linux.org Git - packages/kf5-solid.git/blob - kf5-solid.spec
- up to 5.4.0
[packages/kf5-solid.git] / kf5-solid.spec
1 # TODO:
2 # - dir /usr/include/KF5 not packaged
3 %define         kdeframever     5.4
4 %define         qtver           5.3.2
5 %define         kfname          solid
6
7 Summary:        Desktop hardware abstraction
8 Name:           kf5-%{kfname}
9 Version:        5.4.0
10 Release:        0.1
11 License:        LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  361b9d43063356aa275e43b73e212325
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Concurrent-devel >= %{qtver}
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5DBus-devel >= %{qtver}
19 BuildRequires:  Qt5Gui-devel >= %{qtver}
20 BuildRequires:  Qt5Test-devel >= %{qtver}
21 BuildRequires:  Qt5Widgets-devel >= %{qtver}
22 BuildRequires:  Qt5Xml-devel >= %{qtver}
23 BuildRequires:  bison
24 BuildRequires:  cmake >= 2.8.12
25 BuildRequires:  flex
26 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
27 BuildRequires:  qt5-linguist >= %{qtver}
28 BuildRequires:  rpmbuild(macros) >= 1.164
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  udev-devel
31 BuildRequires:  xz
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         qt5dir          %{_libdir}/qt5
35
36 %description
37 Solid is a device integration framework. It provides a way of querying
38 and interacting with hardware independently of the underlying
39 operating system.
40
41 It provides the following features for application developers:
42
43 - Hardware Discovery
44 - Power Management
45 - Network Management
46
47
48 %package devel
49 Summary:        Header files for %{kfname} development
50 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
51 Group:          X11/Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53
54 %description devel
55 Header files for %{kfname} development.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe dla programistów używających %{kfname}.
59
60 %prep
61 %setup -q -n %{kfname}-%{version}
62
63 %build
64 install -d build
65 cd build
66 %cmake \
67         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
68         ../
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} -C build/ install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %find_lang %{kfname}5_qt --with-qm
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post -p /sbin/ldconfig
83 %postun -p /sbin/ldconfig
84
85 %files -f %{kfname}5_qt.lang
86 %defattr(644,root,root,755)
87 %doc README.md TODO
88 %attr(755,root,root) %{_bindir}/solid-hardware5
89 %attr(755,root,root) %ghost %{_libdir}/libKF5Solid.so.5
90 %attr(755,root,root) %{_libdir}/libKF5Solid.so.5.4.0
91
92 %files devel
93 %defattr(644,root,root,755)
94 %{_includedir}/KF5/Solid
95 %{_includedir}/KF5/solid_version.h
96 %{_libdir}/cmake/KF5Solid
97 %attr (755,root,root) %{_libdir}/libKF5Solid.so
98 %{qt5dir}/mkspecs/modules/qt_Solid.pri
This page took 0.107472 seconds and 3 git commands to generate.