]> git.pld-linux.org Git - packages/kf5-prison.git/blob - kf5-prison.spec
84e8332822bd0cefcf336e489b519ae8c2306a01
[packages/kf5-prison.git] / kf5-prison.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeframever     5.93
5 %define         qtver           5.9.0
6 %define         kfname          prison
7
8 Summary:        A barcode abstraction layer
9 Name:           kf5-%{kfname}
10 Version:        5.93.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  c1638514863b9d10ed2c34812d8243b8
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel >= %{qtver}
19 BuildRequires:  Qt5Test-devel >= %{qtver}
20 BuildRequires:  Qt5Widgets-devel >= %{qtver}
21 BuildRequires:  cmake >= 2.8.12
22 BuildRequires:  hspell-devel
23 BuildRequires:  hunspell-devel
24 BuildRequires:  kf5-extra-cmake-modules >= %{version}
25 BuildRequires:  libdmtx-devel
26 BuildRequires:  ninja
27 BuildRequires:  qrencode-devel
28 BuildRequires:  rpmbuild(macros) >= 1.164
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 BuildRequires:  zlib-devel
32 BuildRequires:  zxing-cpp-nu-devel >= 1.2.0
33 Requires:       kf5-dirs
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         qt5dir          %{_libdir}/qt5
37
38 %description
39 Prison has a Prison::AbstractBarcode, which is the base class for the
40 actual barcode generators, currently Prison::QRCodeBarcode and
41 Prison::DataMatrixBarcode are the two implemented barcode generators.
42
43 Prison currently ships a BarcodeWidget, which is a QWidget with a
44 barcode painted upon, as well as a BarcodeItem, which is a
45 QGraphicsItem with a barcode painted upon.
46
47 %package devel
48 Summary:        Header files for %{kfname} development
49 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
50 Group:          X11/Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52
53 %description devel
54 Header files for %{kfname} development.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe dla programistów używających %{kfname}.
58
59 %prep
60 %setup -q -n %{kfname}-%{version}
61
62 %build
63 install -d build
64 cd build
65 %cmake -G Ninja \
66         %{!?with_tests:-DBUILD_TESTING=OFF} \
67         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
68         ../
69 %ninja_build
70
71 %if %{with tests}
72 ctest
73 %endif
74
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 %ninja_install -C build
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post -p /sbin/ldconfig
84 %postun -p /sbin/ldconfig
85
86 %files
87 %defattr(644,root,root,755)
88 %{_datadir}/qlogging-categories5/prison.categories
89 %ghost %{_libdir}/libKF5Prison.so.5
90 %{_libdir}/libKF5Prison.so.5.*.*
91 %{_libdir}/qt5/qml/org/kde/prison
92 %{_datadir}/qlogging-categories5/prison.renamecategories
93
94 %files devel
95 %defattr(644,root,root,755)
96 %{_includedir}/KF5/Prison
97 %{_libdir}/cmake/KF5Prison
98 %{_libdir}/qt5/mkspecs/modules/qt_Prison.pri
99 %{_libdir}/libKF5Prison.so
This page took 0.1163 seconds and 2 git commands to generate.