]> git.pld-linux.org Git - packages/kf5-prison.git/blob - kf5-prison.spec
6422fffd6e32543b0b1b46f8c797ba2e6f80c51c
[packages/kf5-prison.git] / kf5-prison.spec
1 %define         kdeframever     5.67
2 %define         qtver           5.9.0
3 %define         kfname          prison
4
5 Summary:        A barcode abstraction layer
6 Name:           kf5-%{kfname}
7 Version:        5.67.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  181d901dbda09ee7d26fd234eef56ed4
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  Qt5Gui-devel >= %{qtver}
16 BuildRequires:  Qt5Test-devel >= %{qtver}
17 BuildRequires:  Qt5Widgets-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  hspell-devel
20 BuildRequires:  hunspell-devel
21 BuildRequires:  kf5-extra-cmake-modules >= %{version}
22 BuildRequires:  libdmtx-devel
23 BuildRequires:  ninja
24 BuildRequires:  qrencode-devel
25 BuildRequires:  rpmbuild(macros) >= 1.164
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 BuildRequires:  zlib-devel
29 Requires:       kf5-dirs
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         qt5dir          %{_libdir}/qt5
33
34 %description
35 Prison has a Prison::AbstractBarcode, which is the base class for the
36 actual barcode generators, currently Prison::QRCodeBarcode and
37 Prison::DataMatrixBarcode are the two implemented barcode generators.
38
39 Prison currently ships a BarcodeWidget, which is a QWidget with a
40 barcode painted upon, as well as a BarcodeItem, which is a
41 QGraphicsItem with a barcode painted upon.
42
43 %package devel
44 Summary:        Header files for %{kfname} development
45 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
46 Group:          X11/Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48
49 %description devel
50 Header files for %{kfname} development.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe dla programistów używających %{kfname}.
54
55 %prep
56 %setup -q -n %{kfname}-%{version}
57
58 %build
59 install -d build
60 cd build
61 %cmake -G Ninja \
62         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
63         ../
64 %ninja_build
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 %ninja_install -C build
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post -p /sbin/ldconfig
74 %postun -p /sbin/ldconfig
75
76 %files
77 %defattr(644,root,root,755)
78 %{_datadir}/qlogging-categories5/prison.categories
79 %ghost %{_libdir}/libKF5Prison.so.5
80 %{_libdir}/libKF5Prison.so.5.*.*
81 %{_libdir}/qt5/qml/org/kde/prison
82
83 %files devel
84 %defattr(644,root,root,755)
85 %{_includedir}/KF5/prison
86 %{_includedir}/KF5/prison_version.h
87 %{_libdir}/cmake/KF5Prison
88 %{_libdir}/qt5/mkspecs/modules/qt_Prison.pri
89 %{_libdir}/libKF5Prison.so
This page took 0.058481 seconds and 2 git commands to generate.