]> git.pld-linux.org Git - packages/kf5-oxygen-icons5.git/blob - kf5-oxygen-icons5.spec
46d4677113699e32622c5dfa5524d259e5e99e6c
[packages/kf5-oxygen-icons5.git] / kf5-oxygen-icons5.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeframever     5.98
5 %define         qtver           5.15.2
6 %define         kfname          oxygen-icons5
7
8 Summary:        oxygen icons
9 Name:           kf5-%{kfname}
10 Version:        5.98.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  72089087110a26086ed195250443258a
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Test-devel >= %{qtver}
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  gettext-devel
21 BuildRequires:  kf5-extra-cmake-modules >= %{version}
22 BuildRequires:  ninja
23 BuildRequires:  pkgconfig
24 BuildRequires:  qt5-linguist >= %{qtver}
25 BuildRequires:  rpmbuild(macros) >= 1.164
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 BuildArch:      noarch
29 Requires:       kf5-dirs
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         qt5dir          %{_libdir}/qt5
33
34 %description
35 Oxygen-icons is a freedesktop.org compatible icon theme.
36
37 %prep
38 %setup -q -n %{kfname}-%{version}
39
40 %build
41 install -d build
42 cd build
43 %cmake -G Ninja \
44         %{!?with_tests:-DBUILD_TESTING=OFF} \
45         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
46         ../
47 %ninja_build
48
49 %if %{with tests}
50 ctest
51 %endif
52
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 %ninja_install -C build
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %{_iconsdir}/oxygen
This page took 0.077243 seconds and 2 git commands to generate.