]> git.pld-linux.org Git - packages/kf5-kwindowsystem.git/blob - kf5-kwindowsystem.spec
- updated to 5.88.0
[packages/kf5-kwindowsystem.git] / kf5-kwindowsystem.spec
1 %define         kdeframever     5.88
2 %define         qtver           5.15.2
3 %define         kfname          kwindowsystem
4
5 Summary:        Access to the windowing system
6 Name:           kf5-%{kfname}
7 Version:        5.88.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  d190beadc19b6d6d9351cf347ce486f5
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  Qt5Gui-devel >= %{qtver}
16 BuildRequires:  Qt5Test-devel >= %{qtver}
17 BuildRequires:  Qt5Widgets-devel >= %{qtver}
18 BuildRequires:  Qt5X11Extras-devel >= %{qtver}
19 BuildRequires:  cmake >= 3.16
20 BuildRequires:  kf5-extra-cmake-modules >= %{version}
21 BuildRequires:  libxcb-devel
22 BuildRequires:  ninja
23 BuildRequires:  pkgconfig
24 BuildRequires:  qt5-linguist >= %{qtver}
25 BuildRequires:  rpmbuild(macros) >= 1.736
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xcb-util-keysyms-devel
28 BuildRequires:  xcb-util-wm-devel
29 BuildRequires:  xorg-lib-libX11-devel
30 BuildRequires:  xorg-lib-libXfixes-devel
31 BuildRequires:  xz
32 Requires:       Qt5Gui >= %{qtver}
33 Requires:       Qt5Widgets >= %{qtver}
34 Requires:       Qt5X11Extras >= %{qtver}
35 Requires:       kf5-dirs
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         qt5dir          %{_libdir}/qt5
39
40 %description
41 Convenience access to certain properties and features of the windowing
42 system.
43
44 KWindowSystem provides information about the windowing system and
45 allows interaction with the windowing system. It provides an high
46 level API which is windowing system independent and has platform
47 specific implementations. This API is inspired by X11 and thus not all
48 functionality is available on all windowing systems.
49
50 In addition to the high level API, this framework also provides
51 several more low level classes for interaction with the X Windowing
52 System.
53
54 %package devel
55 Summary:        Header files for %{kfname} development
56 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
57 Group:          X11/Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       Qt5Widgets-devel >= %{qtver}
60
61 %description devel
62 Header files for %{kfname} development.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe dla programistów używających %{kfname}.
66
67 %prep
68 %setup -q -n %{kfname}-%{version}
69
70 %build
71 install -d build
72 cd build
73 %cmake -G Ninja \
74         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
75         ../
76 %ninja_build
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 %ninja_install -C build
81
82 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files -f %{kfname}5_qt.lang
91 %defattr(644,root,root,755)
92 %doc README.md
93 %attr(755,root,root) %ghost %{_libdir}/libKF5WindowSystem.so.5
94 %attr(755,root,root) %{_libdir}/libKF5WindowSystem.so.*.*
95 %dir %{_libdir}/qt5/plugins/kf5/kwindowsystem
96 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kwindowsystem/KF5WindowSystemWaylandPlugin.so
97 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kwindowsystem/KF5WindowSystemX11Plugin.so
98 %{_datadir}/qlogging-categories5/kwindowsystem.renamecategories
99 %{_datadir}/qlogging-categories5/kwindowsystem.categories
100
101 %files devel
102 %defattr(644,root,root,755)
103 %{_includedir}/KF5/KWindowSystem
104 %{_includedir}/KF5/kwindowsystem_version.h
105 %{_libdir}/cmake/KF5WindowSystem
106 %{_libdir}/libKF5WindowSystem.so
107 %{qt5dir}/mkspecs/modules/qt_KWindowSystem.pri
This page took 0.065224 seconds and 3 git commands to generate.