]> git.pld-linux.org Git - packages/kf5-kwindowsystem.git/blob - kf5-kwindowsystem.spec
82478a8f9e8838a9c3e5c4e73abdcdc20cc24a0d
[packages/kf5-kwindowsystem.git] / kf5-kwindowsystem.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeframever     5.102
5 %define         qtver           5.15.2
6 %define         kfname          kwindowsystem
7
8 Summary:        Access to the windowing system
9 Name:           kf5-%{kfname}
10 Version:        5.102.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  4ea43f2680e240fb80c6fe9ef7738cd7
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel >= %{qtver}
19 BuildRequires:  Qt5Test-devel >= %{qtver}
20 BuildRequires:  Qt5Widgets-devel >= %{qtver}
21 BuildRequires:  Qt5X11Extras-devel >= %{qtver}
22 BuildRequires:  cmake >= 3.16
23 BuildRequires:  kf5-extra-cmake-modules >= %{version}
24 BuildRequires:  libxcb-devel
25 BuildRequires:  ninja
26 BuildRequires:  pkgconfig
27 BuildRequires:  qt5-linguist >= %{qtver}
28 BuildRequires:  rpmbuild(macros) >= 1.736
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xcb-util-keysyms-devel
31 BuildRequires:  xcb-util-wm-devel
32 BuildRequires:  xorg-lib-libX11-devel
33 BuildRequires:  xorg-lib-libXfixes-devel
34 BuildRequires:  xz
35 Requires:       Qt5Gui >= %{qtver}
36 Requires:       Qt5Widgets >= %{qtver}
37 Requires:       Qt5X11Extras >= %{qtver}
38 Requires:       kf5-dirs
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         qt5dir          %{_libdir}/qt5
42
43 %description
44 Convenience access to certain properties and features of the windowing
45 system.
46
47 KWindowSystem provides information about the windowing system and
48 allows interaction with the windowing system. It provides an high
49 level API which is windowing system independent and has platform
50 specific implementations. This API is inspired by X11 and thus not all
51 functionality is available on all windowing systems.
52
53 In addition to the high level API, this framework also provides
54 several more low level classes for interaction with the X Windowing
55 System.
56
57 %package devel
58 Summary:        Header files for %{kfname} development
59 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
60 Group:          X11/Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       Qt5Widgets-devel >= %{qtver}
63
64 %description devel
65 Header files for %{kfname} development.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe dla programistów używających %{kfname}.
69
70 %prep
71 %setup -q -n %{kfname}-%{version}
72
73 %build
74 install -d build
75 cd build
76 %cmake -G Ninja \
77         %{!?with_tests:-DBUILD_TESTING=OFF} \
78         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
79         ../
80 %ninja_build
81
82 %if %{with tests}
83 ctest
84 %endif
85
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 %ninja_install -C build
90
91 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files -f %{kfname}5_qt.lang
100 %defattr(644,root,root,755)
101 %doc README.md
102 %ghost %{_libdir}/libKF5WindowSystem.so.5
103 %attr(755,root,root) %{_libdir}/libKF5WindowSystem.so.*.*
104 %dir %{_libdir}/qt5/plugins/kf5/kwindowsystem
105 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kwindowsystem/KF5WindowSystemX11Plugin.so
106 %{_datadir}/qlogging-categories5/kwindowsystem.renamecategories
107 %{_datadir}/qlogging-categories5/kwindowsystem.categories
108
109 %files devel
110 %defattr(644,root,root,755)
111 %{_includedir}/KF5/KWindowSystem
112 %{_libdir}/cmake/KF5WindowSystem
113 %{_libdir}/libKF5WindowSystem.so
114 %{qt5dir}/mkspecs/modules/qt_KWindowSystem.pri
This page took 0.068063 seconds and 2 git commands to generate.