]> git.pld-linux.org Git - packages/kf5-kwindowsystem.git/blob - kf5-kwindowsystem.spec
- Up to 5.67.0.
[packages/kf5-kwindowsystem.git] / kf5-kwindowsystem.spec
1 %define         kdeframever     5.67
2 %define         qtver           5.9.0
3 %define         kfname          kwindowsystem
4
5 Summary:        Access to the windowing system
6 Name:           kf5-%{kfname}
7 Version:        5.67.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  b1d0b95573ff7cfe1ff4d468e7f9fed6
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  Qt5Gui-devel >= %{qtver}
16 BuildRequires:  Qt5Test-devel >= %{qtver}
17 BuildRequires:  Qt5Widgets-devel >= %{qtver}
18 BuildRequires:  Qt5X11Extras-devel >= %{qtver}
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
21 BuildRequires:  libxcb-devel
22 BuildRequires:  ninja
23 BuildRequires:  pkgconfig
24 BuildRequires:  qt5-linguist >= %{qtver}
25 BuildRequires:  rpmbuild(macros) >= 1.164
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xcb-util-keysyms-devel
28 BuildRequires:  xz
29 Requires:       kf5-dirs
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         qt5dir          %{_libdir}/qt5
33
34 %description
35 Convenience access to certain properties and features of the windowing
36 system.
37
38 KWindowSystem provides information about the windowing system and
39 allows interaction with the windowing system. It provides an high
40 level API which is windowing system independent and has platform
41 specific implementations. This API is inspired by X11 and thus not all
42 functionality is available on all windowing systems.
43
44 In addition to the high level API, this framework also provides
45 several more low level classes for interaction with the X Windowing
46 System.
47
48 %package devel
49 Summary:        Header files for %{kfname} development
50 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
51 Group:          X11/Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53
54 %description devel
55 Header files for %{kfname} development.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe dla programistów używających %{kfname}.
59
60 %prep
61 %setup -q -n %{kfname}-%{version}
62
63 %build
64 install -d build
65 cd build
66 %cmake -G Ninja \
67         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
68         ../
69 %ninja_build
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 %ninja_install -C build
74
75 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files -f %{kfname}5_qt.lang
84 %defattr(644,root,root,755)
85 %doc README.md
86 %attr(755,root,root) %ghost %{_libdir}/libKF5WindowSystem.so.5
87 %attr(755,root,root) %{_libdir}/libKF5WindowSystem.so.*.*
88 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/org.kde.kwindowsystem.platforms/KF5WindowSystemWaylandPlugin.so
89 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/org.kde.kwindowsystem.platforms/KF5WindowSystemX11Plugin.so
90 %{_datadir}/qlogging-categories5/kwindowsystem.categories
91
92 %files devel
93 %defattr(644,root,root,755)
94 %{_includedir}/KF5/KWindowSystem
95 %{_includedir}/KF5/kwindowsystem_version.h
96 %{_libdir}/cmake/KF5WindowSystem
97 %{_libdir}/libKF5WindowSystem.so
98 %{qt5dir}/mkspecs/modules/qt_KWindowSystem.pri
This page took 0.068156 seconds and 3 git commands to generate.