]> git.pld-linux.org Git - packages/kf5-kwidgetsaddons.git/blob - kf5-kwidgetsaddons.spec
00e4ac0b25f2b2225807ed86601768fbb5662d53
[packages/kf5-kwidgetsaddons.git] / kf5-kwidgetsaddons.spec
1 # TODO:
2 # - dir /usr/include/KF5 not packaged
3 # /usr/share/kf5 not packaged
4 %define         kdeframever     5.4
5 %define         qtver           5.3.2
6 %define         kfname          kwidgetsaddons
7
8 Summary:        Large set of desktop widgets
9 Name:           kf5-%{kfname}
10 Version:        5.4.0
11 Release:        0.1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  ac2a39d3de060c91c3f65d21a21d6693
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel >= %{qtver}
19 BuildRequires:  Qt5Test-devel >= %{qtver}
20 BuildRequires:  Qt5UiTools-devel >= %{qtver}
21 BuildRequires:  Qt5Widgets-devel >= %{qtver}
22 BuildRequires:  cmake >= 2.8.12
23 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
24 BuildRequires:  qt5-linguist >= %{qtver}
25 BuildRequires:  rpmbuild(macros) >= 1.164
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         qt5dir          %{_libdir}/qt5
31
32 %description
33 This repository contains add-on widgets and classes for applications
34 that use the Qt Widgets module. If you are porting applications from
35 KDE Platform 4 "kdeui" library, you will find many of its classes
36 here.
37
38 Provided are action classes that can be added to toolbars or menus, a
39 wide range of widgets for selecting characters, fonts, colors,
40 actions, dates and times, or MIME types, as well as platform-aware
41 dialogs for configuration pages, message boxes, and password requests.
42
43 Further widgets and classes can be found in other KDE frameworks. For
44 a full list, please see
45 <https://projects.kde.org/projects/frameworks/>
46
47
48 %package devel
49 Summary:        Header files for %{kfname} development
50 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
51 Group:          X11/Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53
54 %description devel
55 Header files for %{kfname} development.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe dla programistów używających %{kfname}.
59
60 %prep
61 %setup -q -n %{kfname}-%{version}
62
63 %build
64 install -d build
65 cd build
66 %cmake \
67         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
68         ../
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} -C build/ install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %find_lang %{kfname}5_qt --with-qm
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post -p /sbin/ldconfig
83 %postun -p /sbin/ldconfig
84
85 %files -f %{kfname}5_qt.lang
86 %defattr(644,root,root,755)
87 %doc README.md
88 %attr(755,root,root) %ghost %{_libdir}/libKF5WidgetsAddons.so.5
89 %attr(755,root,root) %{_libdir}/libKF5WidgetsAddons.so.5.4.0
90 %dir %{_datadir}/kf5/kcharselect
91 %{_datadir}/kf5/kcharselect/kcharselect-data
92
93 %files devel
94 %defattr(644,root,root,755)
95 %{_includedir}/KF5/KWidgetsAddons
96 %{_includedir}/KF5/kwidgetsaddons_version.h
97 %{_libdir}/cmake/KF5WidgetsAddons
98 %attr(755,root,root) %{_libdir}/libKF5WidgetsAddons.so
99 %{qt5dir}/mkspecs/modules/qt_KWidgetsAddons.pri
This page took 0.079999 seconds and 2 git commands to generate.