]> git.pld-linux.org Git - packages/kf5-kwayland.git/blob - kf5-kwayland.spec
- updated to 5.101.0
[packages/kf5-kwayland.git] / kf5-kwayland.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeframever     5.101
5 %define         qtver           5.15.2
6 %define         kfname          kwayland
7
8 Summary:        Qt-style API to interact with the wayland-client and wayland-server API
9 Summary(pl.UTF-8):      API w stylu Qt do interakcji z API wayland-client i wayland-server
10 Name:           kf5-%{kfname}
11 Version:        5.101.0
12 Release:        1
13 License:        LGPL v2.1 or KDE-accepted LGPL v3+
14 Group:          X11/Libraries
15 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
16 # Source0-md5:  9424f989d07126b2dda5d4e416cd35fc
17 URL:            http://www.kde.org/
18 BuildRequires:  EGL-devel
19 BuildRequires:  Qt5Concurrent-devel >= %{qtver}
20 BuildRequires:  Qt5Core-devel >= %{qtver}
21 BuildRequires:  Qt5Gui-devel >= %{qtver}
22 BuildRequires:  Qt5Test-devel >= %{qtver}
23 BuildRequires:  Qt5WaylandClient-devel >= %{qtver}
24 BuildRequires:  Qt5Widgets-devel >= %{qtver}
25 BuildRequires:  cmake >= 3.16
26 BuildRequires:  gettext-devel
27 BuildRequires:  kf5-extra-cmake-modules >= %{version}
28 BuildRequires:  kf5-plasma-wayland-protocols-devel >= 1.9.0
29 BuildRequires:  ninja
30 BuildRequires:  pkgconfig
31 BuildRequires:  rpmbuild(macros) >= 1.736
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  wayland-devel >= 1.15
34 BuildRequires:  wayland-protocols >= 1.15
35 BuildRequires:  xz
36 Requires:       Qt5Core >= %{qtver}
37 Requires:       Qt5Gui >= %{qtver}
38 Requires:       wayland >= 1.15
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 KWayland is a Qt-style API to interact with the wayland-client and
43 wayland-server API.
44
45 %description -l pl.UTF-8
46 KWayland to API w stylu Qt do interakcji z API wayland-client i
47 wayland-server.
48
49 %package devel
50 Summary:        Header files for %{kfname} development
51 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
52 Group:          X11/Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       Qt5Gui-devel >= %{qtver}
55
56 %description devel
57 Header files for %{kfname} development.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe dla programistów używających %{kfname}.
61
62 %prep
63 %setup -q -n %{kfname}-%{version}
64
65 %build
66 install -d build
67 cd build
68 %cmake -G Ninja \
69         %{!?with_tests:-DBUILD_TESTING=OFF} \
70         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
71         ../
72
73 %ninja_build
74
75 %if %{with tests}
76 ctest
77 %endif
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %ninja_install -C build
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc README.md LICENSES/LicenseRef-KDE-Accepted-LGPL.txt
93 %ghost %{_libdir}/libKF5WaylandClient.so.5
94 %attr(755,root,root) %{_libdir}/libKF5WaylandClient.so.5.*.*
95 %ghost %{_libdir}/libKF5WaylandServer.so.5
96 %attr(755,root,root) %{_libdir}/libKF5WaylandServer.so.5.*.*
97 %attr(755,root,root) %{_libexecdir}/org-kde-kf5-kwayland-testserver
98 %{_datadir}/qlogging-categories5/kwayland.categories
99 %{_datadir}/qlogging-categories5/kwayland.renamecategories
100
101 %files devel
102 %defattr(644,root,root,755)
103 %{_libdir}/libKF5WaylandClient.so
104 %{_libdir}/libKF5WaylandServer.so
105 %{_includedir}/KF5/KWayland
106 %{_pkgconfigdir}/KF5WaylandClient.pc
107 %{_libdir}/cmake/KF5Wayland
108 %{_libdir}/qt5/mkspecs/modules/qt_KWaylandClient.pri
109 %{_libdir}/qt5/mkspecs/modules/qt_KWaylandServer.pri
This page took 0.155397 seconds and 3 git commands to generate.