]> git.pld-linux.org Git - packages/kf5-kquickcharts.git/blob - kf5-kquickcharts.spec
- updated to 5.98.0
[packages/kf5-kquickcharts.git] / kf5-kquickcharts.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeframever     5.98
5 %define         qtver           5.15.2
6 %define         kfname          kquickcharts
7
8 Summary:        Plugin for beautiful and interactive charts
9 Name:           kf5-%{kfname}
10 Version:        5.98.0
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  1eb575efbf2e585491ed9af0dfd5994c
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel
19 BuildRequires:  Qt5Network-devel >= 5.11.1
20 BuildRequires:  Qt5Qml-devel
21 BuildRequires:  Qt5Quick-devel
22 BuildRequires:  cmake >= 2.8.12
23 BuildRequires:  kf5-extra-cmake-modules >= %{kdeframever}
24 BuildRequires:  ninja
25 BuildRequires:  qt5-build >= %{qtver}
26 BuildRequires:  rpmbuild(macros) >= 1.164
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Qt Quick plugin for beautiful and interactive charts.
33
34 %package devel
35 Summary:        Header files for %{kaname} development
36 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kaname}
37 Group:          X11/Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description devel
41 Header files for %{kfname} development.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe dla programistów używających %{kaname}.
45
46 %prep
47 %setup -q -n %{kfname}-%{version}
48
49 %build
50 install -d build
51 cd build
52 %cmake \
53         -G Ninja \
54         %{!?with_tests:-DBUILD_TESTING=OFF} \
55         -DHTML_INSTALL_DIR=%{_kdedocdir} \
56         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
57         ..
58 %ninja_build
59
60 %if %{with tests}
61 ctest
62 %endif
63
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 %ninja_install -C build
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %dir %{_libdir}/qt5/qml/org/kde/quickcharts
75 %dir %{_libdir}/qt5/qml/org/kde/quickcharts/controls
76 %dir %{_libdir}/qt5/qml/org/kde/quickcharts/controls/styles
77 %dir %{_libdir}/qt5/qml/org/kde/quickcharts/controls/styles/org.kde.desktop
78 %{_libdir}/qt5/qml/org/kde/quickcharts/controls/libQuickChartsControls.so
79 %{_libdir}/qt5/qml/org/kde/quickcharts/controls/styles/org.kde.desktop/Theme.qml
80 %{_libdir}/qt5/qml/org/kde/quickcharts/controls/qmldir
81 %{_libdir}/qt5/qml/org/kde/quickcharts/controls/Theme.qml
82 %{_libdir}/qt5/qml/org/kde/quickcharts/controls/PieChartControl.qml
83 %{_libdir}/qt5/qml/org/kde/quickcharts/controls/LegendDelegate.qml
84 %{_libdir}/qt5/qml/org/kde/quickcharts/controls/LineChartControl.qml
85 %{_libdir}/qt5/qml/org/kde/quickcharts/controls/Legend.qml
86 %{_libdir}/qt5/qml/org/kde/quickcharts/controls/Logging.qml
87 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/quickcharts/libQuickCharts.so
88 %{_libdir}/qt5/qml/org/kde/quickcharts/qmldir
89 %{_datadir}/qlogging-categories5/kquickcharts.categories
90
91 %files devel
92 %defattr(644,root,root,755)
93 # %{_includedir}/KF5/kqtquickcharts_version.h
94 %{_libdir}/cmake/KF5QuickCharts
This page took 0.096568 seconds and 3 git commands to generate.