]> git.pld-linux.org Git - packages/kf5-kplotting.git/blob - kf5-kplotting.spec
90329948eb2f5fdd8781481fa639b40649ef932b
[packages/kf5-kplotting.git] / kf5-kplotting.spec
1 %define         kdeframever     5.13
2 %define         qtver           5.3.2
3 %define         kfname          kplotting
4 #
5 Summary:        Data plotting
6 Name:           kf5-%{kfname}
7 Version:        5.13.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  4177271c93a3c8094620bd615761fbd9
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel
15 BuildRequires:  Qt5Gui-devel >= 5.3.1
16 BuildRequires:  Qt5Test-devel
17 BuildRequires:  Qt5Widgets-devel
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
20 BuildRequires:  rpmbuild(macros) >= 1.164
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         qt5dir          %{_libdir}/qt5
26
27 %description
28 KPlotWidget is a QWidget-derived class that provides a virtual base
29 class for easy data-plotting. The idea behind KPlotWidget is that you
30 only have to specify information in "data units"; i.e., the natural
31 units of the data being plotted. KPlotWidget automatically converts
32 everything to screen pixel units.
33
34 KPlotWidget draws X and Y axes with tick marks and tick labels. It
35 automatically determines how many tick marks to use and where they
36 should be, based on the data limits specified for the plot. You change
37 the limits by calling `setLimits(double x1, double x2, double y1,
38 double y2)`.
39
40 Data to be plotted are stored using the KPlotObject class. KPlotObject
41 consists of a QList of QPointF's, each specifying the X,Y coordinates
42 of a data point. KPlotObject also specifies the "type" of data to be
43 plotted (POINTS or CURVE or POLYGON or LABEL).
44
45 %package devel
46 Summary:        Header files for %{kfname} development
47 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
48 Group:          X11/Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50
51 %description devel
52 Header files for %{kfname} development.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe dla programistów używających %{kfname}.
56
57 %prep
58 %setup -q -n %{kfname}-%{version}
59
60 %build
61 install -d build
62 cd build
63 %cmake \
64         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
65         ../
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} -C build/ install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post -p /sbin/ldconfig
78 %postun -p /sbin/ldconfig
79
80 %files
81 %defattr(644,root,root,755)
82 %doc README.md
83 %attr(755,root,root) %ghost %{_libdir}/libKF5Plotting.so.5
84 %attr(755,root,root) %{_libdir}/libKF5Plotting.so.*.**
85
86 %files devel
87 %defattr(644,root,root,755)
88 %{_includedir}/KF5/KPlotting
89 %{_includedir}/KF5/kplotting_version.h
90 %{_libdir}/cmake/KF5Plotting
91 %attr(755,root,root) %{_libdir}/libKF5Plotting.so
92 %{qt5dir}/mkspecs/modules/qt_KPlotting.pri
This page took 0.070211 seconds and 2 git commands to generate.