]> git.pld-linux.org Git - packages/kf5-kpeople.git/blob - kf5-kpeople.spec
- updated to 5.97.0
[packages/kf5-kpeople.git] / kf5-kpeople.spec
1 # Conditional build:
2 %bcond_with     tests           # build without tests
3 #
4 %define         kdeframever     5.97
5 %define         qtver           5.15.2
6 %define         kfname          kpeople
7 Summary:        Provides access to all contacts and the people who hold them
8 Name:           kf5-%{kfname}
9 Version:        5.97.0
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  2c0c9727577fd9c3ad76edb9782c7ef2
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Gui-devel >= %{qtver}
18 BuildRequires:  Qt5Network-devel >= %{qtver}
19 BuildRequires:  Qt5Test-devel >= %{qtver}
20 %if %{with tests}
21 BuildRequires:  Qt5Gui-devel >= %{qtver}
22 BuildRequires:  Qt5Widgets-devel >= %{qtver}
23 %endif
24 BuildRequires:  cmake >= 2.8.12
25 BuildRequires:  kf5-extra-cmake-modules >= %{version}
26 BuildRequires:  kf5-kcoreaddons-devel >= %{version}
27 BuildRequires:  ninja
28 BuildRequires:  qt5-build >= %{qtver}
29 BuildRequires:  rpmbuild(macros) >= 1.164
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xz
32 Requires:       kf5-dirs
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Provides access to all contacts and the people who hold them.
37
38 %package devel
39 Summary:        Header files for %{kfname} development
40 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
41 Group:          X11/Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 Header files for %{kfname} development.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe dla programistów używających %{kfname}.
49
50 %prep
51 %setup -q -n %{kfname}-%{version}
52
53 %build
54 install -d build
55 cd build
56 %cmake -G Ninja \
57         %{!?with_tests:-DBUILD_TESTING=OFF} \
58         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
59         ..
60 %ninja_build
61
62 %{?with_tests:%ninja_build test}
63
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 %ninja_install -C build
68
69 %find_lang %{kfname}5 --all-name --with-kde
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post   -p /sbin/ldconfig
75 %postun -p /sbin/ldconfig
76
77 %files -f %{kfname}5.lang
78 %defattr(644,root,root,755)
79 %doc README.md
80 %{_datadir}/qlogging-categories5/kpeople.categories
81 %attr(755,root,root) %{_libdir}/libKF5People.so.*.*.*
82 %ghost %{_libdir}/libKF5People.so.5
83 %attr(755,root,root) %{_libdir}/libKF5PeopleBackend.so.*.*.*
84 %ghost %{_libdir}/libKF5PeopleBackend.so.5
85 %attr(755,root,root) %{_libdir}/libKF5PeopleWidgets.so.*.*.*
86 %ghost %{_libdir}/libKF5PeopleWidgets.so.5
87 %dir %{_libdir}/qt5/qml/org/kde/people
88 %{_libdir}/qt5/qml/org/kde/people/qmldir
89 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/people/libKF5PeopleDeclarative.so
90 %{_datadir}/qlogging-categories5/kpeople.renamecategories
91
92 %files devel
93 %defattr(644,root,root,755)
94 %{_libdir}/libKF5People.so
95 %{_libdir}/libKF5PeopleBackend.so
96 %{_libdir}/libKF5PeopleWidgets.so
97 %{_includedir}/KF5/KPeople
98 %{_libdir}/cmake/KF5People
99 %{_libdir}/qt5/mkspecs/modules/qt_KPeople*.pri
This page took 0.085651 seconds and 3 git commands to generate.