]> git.pld-linux.org Git - packages/kf5-kitemmodels.git/blob - kf5-kitemmodels.spec
e804b1d111887143ac5d66d39c002bddf9601207
[packages/kf5-kitemmodels.git] / kf5-kitemmodels.spec
1 %define         kdeframever     5.85
2 %define         qtver           5.9.0
3 %define         kfname          kitemmodels
4
5 Summary:        Set of item models extending the Qt model-view framework
6 Name:           kf5-%{kfname}
7 Version:        5.85.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  3f00cbe1c9ded4b9f061f0dcc3c38071
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  Qt5Gui-devel >= %{qtver}
16 BuildRequires:  Qt5Test-devel >= %{qtver}
17 BuildRequires:  Qt5Widgets-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  kf5-extra-cmake-modules >= %{version}
20 BuildRequires:  ninja
21 BuildRequires:  qt5-linguist >= %{qtver}
22 BuildRequires:  rpmbuild(macros) >= 1.164
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 Requires:       kf5-dirs
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         qt5dir          %{_libdir}/qt5
29
30 %description
31 KItemModels provides the following models:
32
33 - KBreadcrumbSelectionModel - Selects the parents of selected items to
34   create breadcrumbs
35 - KCheckableProxyModel - Adds a checkable capability to a source model
36 - KDescendantsProxyModel - Proxy Model for restructuring a Tree into a
37   list
38 - KLinkItemSelectionModel - Share a selection in multiple views which
39   do not have the same source model
40 - KModelIndexProxyMapper - Mapping of indexes and selections through
41   proxy models
42 - KRecursiveFilterProxyModel - Recursive filtering of models
43 - KSelectionProxyModel - A Proxy Model which presents a subset of its
44   source model to observers
45
46 %package devel
47 Summary:        Header files for %{kfname} development
48 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
49 Group:          X11/Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 Header files for %{kfname} development.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe dla programistów używających %{kfname}.
57
58 %prep
59 %setup -q -n %{kfname}-%{version}
60
61 %build
62 install -d build
63 cd build
64 %cmake -G Ninja \
65         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
66         ../
67 %ninja_build
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 %ninja_install -C build
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post -p /sbin/ldconfig
77 %postun -p /sbin/ldconfig
78
79 %files
80 %defattr(644,root,root,755)
81 %doc README.md
82 %ghost %{_libdir}/libKF5ItemModels.so.5
83 %attr(755,root,root) %{_libdir}/libKF5ItemModels.so.*.*
84 %dir %{qt5dir}/qml/org/kde/kitemmodels
85 %attr(755,root,root) %{qt5dir}/qml/org/kde/kitemmodels/libitemmodelsplugin.so
86 %{qt5dir}/qml/org/kde/kitemmodels/qmldir
87 %{_datadir}/qlogging-categories5/kitemmodels.categories
88 %{_datadir}/qlogging-categories5/kitemmodels.renamecategories
89
90 %files devel
91 %defattr(644,root,root,755)
92 %{_includedir}/KF5/KItemModels
93 %{_includedir}/KF5/kitemmodels_version.h
94 %{_libdir}/cmake/KF5ItemModels
95 %{_libdir}/libKF5ItemModels.so
96 %{qt5dir}/mkspecs/modules/qt_KItemModels.pri
This page took 0.056479 seconds and 2 git commands to generate.