]> git.pld-linux.org Git - packages/kf5-kitemmodels.git/blob - kf5-kitemmodels.spec
abc00c1092543c3f1cc16caea280435f3840f6b1
[packages/kf5-kitemmodels.git] / kf5-kitemmodels.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeframever     5.97
5 %define         qtver           5.15.2
6 %define         kfname          kitemmodels
7
8 Summary:        Set of item models extending the Qt model-view framework
9 Name:           kf5-%{kfname}
10 Version:        5.97.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  2b35af1ee245563dd5b521e756228e00
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel >= %{qtver}
19 BuildRequires:  Qt5Test-devel >= %{qtver}
20 BuildRequires:  Qt5Widgets-devel >= %{qtver}
21 BuildRequires:  cmake >= 2.8.12
22 BuildRequires:  kf5-extra-cmake-modules >= %{version}
23 BuildRequires:  ninja
24 BuildRequires:  qt5-linguist >= %{qtver}
25 BuildRequires:  rpmbuild(macros) >= 1.164
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 Requires:       kf5-dirs
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         qt5dir          %{_libdir}/qt5
32
33 %description
34 KItemModels provides the following models:
35
36 - KBreadcrumbSelectionModel - Selects the parents of selected items to
37   create breadcrumbs
38 - KCheckableProxyModel - Adds a checkable capability to a source model
39 - KDescendantsProxyModel - Proxy Model for restructuring a Tree into a
40   list
41 - KLinkItemSelectionModel - Share a selection in multiple views which
42   do not have the same source model
43 - KModelIndexProxyMapper - Mapping of indexes and selections through
44   proxy models
45 - KRecursiveFilterProxyModel - Recursive filtering of models
46 - KSelectionProxyModel - A Proxy Model which presents a subset of its
47   source model to observers
48
49 %package devel
50 Summary:        Header files for %{kfname} development
51 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
52 Group:          X11/Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54
55 %description devel
56 Header files for %{kfname} development.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe dla programistów używających %{kfname}.
60
61 %prep
62 %setup -q -n %{kfname}-%{version}
63
64 %build
65 install -d build
66 cd build
67 %cmake -G Ninja \
68         %{!?with_tests:-DBUILD_TESTING=OFF} \
69         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
70         ../
71 %ninja_build
72
73 %if %{with tests}
74 ctest
75 %endif
76
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 %ninja_install -C build
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post -p /sbin/ldconfig
86 %postun -p /sbin/ldconfig
87
88 %files
89 %defattr(644,root,root,755)
90 %doc README.md
91 %ghost %{_libdir}/libKF5ItemModels.so.5
92 %attr(755,root,root) %{_libdir}/libKF5ItemModels.so.*.*
93 %dir %{qt5dir}/qml/org/kde/kitemmodels
94 %attr(755,root,root) %{qt5dir}/qml/org/kde/kitemmodels/libitemmodelsplugin.so
95 %{qt5dir}/qml/org/kde/kitemmodels/qmldir
96 %{_datadir}/qlogging-categories5/kitemmodels.categories
97 %{_datadir}/qlogging-categories5/kitemmodels.renamecategories
98
99 %files devel
100 %defattr(644,root,root,755)
101 %{_includedir}/KF5/KItemModels
102 %{_libdir}/cmake/KF5ItemModels
103 %{_libdir}/libKF5ItemModels.so
104 %{qt5dir}/mkspecs/modules/qt_KItemModels.pri
This page took 0.059746 seconds and 2 git commands to generate.