]> git.pld-linux.org Git - packages/kf5-kitemmodels.git/blob - kf5-kitemmodels.spec
8b81dfcb1d163a4da56747b2c47fc486beea8a68
[packages/kf5-kitemmodels.git] / kf5-kitemmodels.spec
1 # TODO:
2 # - dir /usr/include/KF5 not packaged
3 %define         _state          stable
4 %define         orgname         kitemmodels
5
6 Summary:        Set of item models extending the Qt model-view framework
7 Name:           kf5-%{orgname}
8 Version:        5.0.0
9 Release:        0.1
10 License:        LGPL v2.1+
11 Group:          X11/Libraries
12 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
13 # Source0-md5:  c1bb781f39b2c6d232a0fb490f2aa9dc
14 URL:            http://www.kde.org/
15 BuildRequires:  Qt5Core-devel
16 BuildRequires:  Qt5Gui-devel >= 5.3.1
17 BuildRequires:  Qt5Test-devel
18 BuildRequires:  Qt5Widgets-devel >= 5.2.0
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
21 BuildRequires:  qt5-linguist
22 BuildRequires:  rpmbuild(macros) >= 1.164
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         qt5dir          %{_libdir}/qt5
26
27 %description
28 KItemModels provides the following models:
29
30 - KBreadcrumbSelectionModel - Selects the parents of selected items to
31   create breadcrumbs
32 - KCheckableProxyModel - Adds a checkable capability to a source model
33 - KDescendantsProxyModel - Proxy Model for restructuring a Tree into a
34   list
35 - KLinkItemSelectionModel - Share a selection in multiple views which
36   do not have the same source model
37 - KModelIndexProxyMapper - Mapping of indexes and selections through
38   proxy models
39 - KRecursiveFilterProxyModel - Recursive filtering of models
40 - KSelectionProxyModel - A Proxy Model which presents a subset of its
41   source model to observers
42
43 %package devel
44 Summary:        Header files for %{orgname} development
45 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{orgname}
46 Group:          X11/Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48
49 %description devel
50 Header files for %{orgname} development.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe dla programistów używających %{orgname}.
54
55 %prep
56 %setup -q -n %{orgname}-%{version}
57
58 %build
59 install -d build
60 cd build
61 %cmake \
62         -DBIN_INSTALL_DIR=%{_bindir} \
63         -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
64         -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
65         -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
66         -DQML_INSTALL_DIR=%{qt5dir}/qml \
67         -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
68         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
69         -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
70         -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
71         -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
72         -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
73         ../
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} -C build/ install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post -p /sbin/ldconfig
86 %postun -p /sbin/ldconfig
87
88 %files
89 %defattr(644,root,root,755)
90 %doc README.md
91 %attr(755,root,root) %ghost %{_libdir}/libKF5ItemModels.so.5
92 %attr(755,root,root) %{_libdir}/libKF5ItemModels.so.5.0.0
93
94 %files devel
95 %defattr(644,root,root,755)
96 %{_includedir}/KF5/KItemModels
97 %{_includedir}/KF5/kitemmodels_version.h
98 %{_libdir}/cmake/KF5ItemModels
99 %attr(755,root,root) %{_libdir}/libKF5ItemModels.so
100 %{qt5dir}/mkspecs/modules/qt_KItemModels.pri
This page took 0.174443 seconds and 2 git commands to generate.