]> git.pld-linux.org Git - packages/kf5-kitemmodels.git/blob - kf5-kitemmodels.spec
- up to 5.4.0
[packages/kf5-kitemmodels.git] / kf5-kitemmodels.spec
1 # TODO:
2 # - dir /usr/include/KF5 not packaged
3 %define         kdeframever     5.4
4 %define         qtver           5.3.2
5 %define         kfname          kitemmodels
6
7 Summary:        Set of item models extending the Qt model-view framework
8 Name:           kf5-%{kfname}
9 Version:        5.4.0
10 Release:        0.1
11 License:        LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  2dc52012a41d75a8006fdccefdb95ff3
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Gui-devel >= %{qtver}
18 BuildRequires:  Qt5Test-devel >= %{qtver}
19 BuildRequires:  Qt5Widgets-devel >= %{qtver}
20 BuildRequires:  cmake >= 2.8.12
21 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
22 BuildRequires:  qt5-linguist >= %{qtver}
23 BuildRequires:  rpmbuild(macros) >= 1.164
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  xz
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         qt5dir          %{_libdir}/qt5
29
30 %description
31 KItemModels provides the following models:
32
33 - KBreadcrumbSelectionModel - Selects the parents of selected items to
34   create breadcrumbs
35 - KCheckableProxyModel - Adds a checkable capability to a source model
36 - KDescendantsProxyModel - Proxy Model for restructuring a Tree into a
37   list
38 - KLinkItemSelectionModel - Share a selection in multiple views which
39   do not have the same source model
40 - KModelIndexProxyMapper - Mapping of indexes and selections through
41   proxy models
42 - KRecursiveFilterProxyModel - Recursive filtering of models
43 - KSelectionProxyModel - A Proxy Model which presents a subset of its
44   source model to observers
45
46 %package devel
47 Summary:        Header files for %{kfname} development
48 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
49 Group:          X11/Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 Header files for %{kfname} development.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe dla programistów używających %{kfname}.
57
58 %prep
59 %setup -q -n %{kfname}-%{version}
60
61 %build
62 install -d build
63 cd build
64 %cmake \
65         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
66         ../
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} -C build/ install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %files
82 %defattr(644,root,root,755)
83 %doc README.md
84 %attr(755,root,root) %ghost %{_libdir}/libKF5ItemModels.so.5
85 %attr(755,root,root) %{_libdir}/libKF5ItemModels.so.5.4.0
86
87 %files devel
88 %defattr(644,root,root,755)
89 %{_includedir}/KF5/KItemModels
90 %{_includedir}/KF5/kitemmodels_version.h
91 %{_libdir}/cmake/KF5ItemModels
92 %attr(755,root,root) %{_libdir}/libKF5ItemModels.so
93 %{qt5dir}/mkspecs/modules/qt_KItemModels.pri
This page took 0.062368 seconds and 3 git commands to generate.