]> git.pld-linux.org Git - packages/kf5-kidletime.git/blob - kf5-kidletime.spec
ebb1ba9a355e7b2fded31e2a63563eb39da157e5
[packages/kf5-kidletime.git] / kf5-kidletime.spec
1 # TODO:
2 # - dir /usr/include/KF5 not packaged
3 %define         _state          stable
4 %define         orgname         kidletime
5
6 Summary:        Reporting of idle time of user and system
7 Name:           kf5-%{orgname}
8 Version:        5.0.0
9 Release:        0.1
10 License:        LGPL v2.1+
11 Group:          X11/Libraries
12 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
13 # Source0-md5:  b08db7cd7b55461c6a198e458c928549
14 URL:            http://www.kde.org/
15 BuildRequires:  Qt5Core-devel
16 BuildRequires:  Qt5DBus-devel
17 BuildRequires:  Qt5Gui-devel >= 5.3.1
18 BuildRequires:  Qt5Test-devel
19 BuildRequires:  Qt5Widgets-devel
20 BuildRequires:  Qt5X11Extras-devel >= 5.2.0
21 BuildRequires:  cmake >= 2.8.12
22 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
23 BuildRequires:  qt5-linguist
24 BuildRequires:  rpmbuild(macros) >= 1.164
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  xz
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         qt5dir          %{_libdir}/qt5
30
31 %description
32 KIdleTime is a singleton reporting information on idle time. It is
33 useful not only for finding out about the current idle time of the PC,
34 but also for getting notified upon idle time events, such as custom
35 timeouts, or user activity.
36
37 %package devel
38 Summary:        Header files for %{orgname} development
39 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{orgname}
40 Group:          X11/Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 Header files for %{orgname} development.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe dla programistów używających %{orgname}.
48
49 %prep
50 %setup -q -n %{orgname}-%{version}
51
52 %build
53 install -d build
54 cd build
55 %cmake \
56         -DBIN_INSTALL_DIR=%{_bindir} \
57         -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
58         -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
59         -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
60         -DQML_INSTALL_DIR=%{qt5dir}/qml \
61         -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
62         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
63         -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
64         -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
65         -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
66         -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
67         ../
68 %{__make}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} -C build/ install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files
83 %defattr(644,root,root,755)
84 %doc README.md
85 %attr(755,root,root) %ghost %{_libdir}/libKF5IdleTime.so.5
86 %attr(755,root,root) %{_libdir}/libKF5IdleTime.so.5.0.0
87
88 %files devel
89 %defattr(644,root,root,755)
90 %{_includedir}/KF5/KIdleTime
91 %{_includedir}/KF5/kidletime_version.h
92 %{_libdir}/cmake/KF5IdleTime
93 %attr(755,root,root) %{_libdir}/libKF5IdleTime.so
94 %{qt5dir}/mkspecs/modules/qt_KIdleTime.pri
This page took 0.049222 seconds and 2 git commands to generate.