]> git.pld-linux.org Git - packages/kf5-kiconthemes.git/blob - kf5-kiconthemes.spec
- Up to 5.62.0.
[packages/kf5-kiconthemes.git] / kf5-kiconthemes.spec
1 %define         kdeframever     5.62
2 %define         qtver           5.9.0
3 %define         kfname          kiconthemes
4
5 Summary:        Icon GUI utilities
6 Name:           kf5-%{kfname}
7 Version:        5.62.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  b39d9ceefb394842e5a2b762312a077a
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  Qt5DBus-devel >= %{qtver}
16 BuildRequires:  Qt5Gui-devel >= %{qtver}
17 BuildRequires:  Qt5Svg-devel >= %{qtver}
18 BuildRequires:  Qt5Test-devel >= %{qtver}
19 BuildRequires:  Qt5Widgets-devel >= %{qtver}
20 BuildRequires:  Qt5Xml-devel >= %{qtver}
21 BuildRequires:  cmake >= 2.8.12
22 BuildRequires:  gettext-devel
23 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
24 BuildRequires:  kf5-kauth-devel >= %{version}
25 BuildRequires:  kf5-kcodecs-devel >= %{version}
26 BuildRequires:  kf5-kconfig-devel >= %{version}
27 BuildRequires:  kf5-kconfigwidgets-devel >= %{version}
28 BuildRequires:  kf5-kcoreaddons-devel >= %{version}
29 BuildRequires:  kf5-kguiaddons-devel >= %{version}
30 BuildRequires:  kf5-ki18n-devel >= %{version}
31 BuildRequires:  kf5-kitemviews-devel >= %{version}
32 BuildRequires:  kf5-kwidgetsaddons-devel >= %{version}
33 BuildRequires:  ninja
34 BuildRequires:  pkgconfig
35 BuildRequires:  qt5-linguist >= %{qtver}
36 BuildRequires:  rpmbuild(macros) >= 1.164
37 BuildRequires:  tar >= 1:1.22
38 BuildRequires:  xz
39 Requires:       kf5-dirs
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         qt5dir          %{_libdir}/qt5
43
44 %description
45 This library contains classes to improve the handling of icons in
46 applications using the KDE Frameworks. Provided are:
47
48 - KIconDialog: Dialog class to let the user select an icon from the
49   list of installed icons.
50 - KIconButton: Custom button class that displays an icon. When
51   clicking it, the user can change it using the icon dialog.
52 - KIconEffect: Applies various colorization effects to icons, which
53   can be used to create selected/disabled icon images.
54
55 Other classes in this repository are used internally by the icon theme
56 configuration dialogs, and should not be used by applications.
57
58 %package devel
59 Summary:        Header files for %{kfname} development
60 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
61 Group:          X11/Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63
64 %description devel
65 Header files for %{kfname} development.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe dla programistów używających %{kfname}.
69
70 %prep
71 %setup -q -n %{kfname}-%{version}
72
73 %build
74 install -d build
75 cd build
76 %cmake -G Ninja \
77         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
78         ../
79 %ninja_build
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 %ninja_install -C build
84
85 %find_lang %{kfname}5
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files -f %{kfname}5.lang
94 %defattr(644,root,root,755)
95 %doc README.md
96 %{_datadir}/qlogging-categories5/kiconthemes.categories
97 %attr(755,root,root) %{_bindir}/kiconfinder5
98 %attr(755,root,root) %ghost %{_libdir}/libKF5IconThemes.so.5
99 %attr(755,root,root) %{_libdir}/libKF5IconThemes.so.*.*
100 %attr(755,root,root) %{_libdir}/qt5/plugins/iconengines/KIconEnginePlugin.so
101
102 %files devel
103 %defattr(644,root,root,755)
104 %{_includedir}/KF5/KIconThemes
105 %{_includedir}/KF5/kiconthemes_version.h
106 %{_libdir}/cmake/KF5IconThemes
107 %attr(755,root,root) %{_libdir}/libKF5IconThemes.so
108 %{qt5dir}/mkspecs/modules/qt_KIconThemes.pri
This page took 0.074764 seconds and 3 git commands to generate.