]> git.pld-linux.org Git - packages/kf5-ki18n.git/blob - kf5-ki18n.spec
- updated to 5.116.0
[packages/kf5-ki18n.git] / kf5-ki18n.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 # TODO:
5 # find_lang needs to be updated (to handle pmap, pmapc, js files)
6 %define         kdeframever     5.116
7 %define         qtver           5.15.2
8 %define         kfname          ki18n
9
10 Summary:        KDE Gettext-based UI text internationalization
11 Name:           kf5-%{kfname}
12 Version:        5.116.0
13 Release:        1
14 License:        LGPL v2.1+
15 Group:          X11/Libraries
16 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
17 # Source0-md5:  9341d43aa21be67c84abcc1276ff2c83
18 URL:            http://www.kde.org/
19 BuildRequires:  Qt5Concurrent-devel >= %{qtver}
20 BuildRequires:  Qt5Core-devel >= %{qtver}
21 BuildRequires:  Qt5Qml-devel >= %{qtver}
22 BuildRequires:  Qt5Test-devel >= %{qtver}
23 BuildRequires:  cmake >= 3.16
24 BuildRequires:  kf5-extra-cmake-modules >= %{version}
25 BuildRequires:  ninja
26 BuildRequires:  python3
27 BuildRequires:  rpmbuild(macros) >= 1.736
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 Requires:       Qt5Core >= %{qtver}
31 Requires:       Qt5Qml >= %{qtver}
32 Requires:       kf5-dirs
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         qt5dir          %{_libdir}/qt5
36
37 %description
38 KI18n provides functionality for internationalizing user interface
39 text in applications, based on the GNU Gettext translation system. It
40 wraps the standard Gettext functionality, so that the programmers and
41 translators can use the familiar Gettext tools and workflows.
42
43 KI18n provides additional functionality as well, for both programmers
44 and translators, which can help to achieve a higher overall quality of
45 source and translated text. This includes argument capturing,
46 customizable markup, and translation scripting.
47
48 %package devel
49 Summary:        Header files for %{kfname} development
50 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
51 Group:          X11/Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       cmake >= 3.16
54 Requires:       gettext-tools
55
56 %description devel
57 Header files for %{kfname} development.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe dla programistów używających %{kfname}.
61
62 %prep
63 %setup -q -n %{kfname}-%{version}
64
65 %build
66 %cmake -B build \
67         -G Ninja \
68         %{!?with_tests:-DBUILD_TESTING=OFF} \
69         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
70
71 %ninja_build -C build
72
73 %if %{with tests}
74 %ninja_build -C build test
75 %endif
76
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 %ninja_install -C build
81
82 # not supported by glibc yet
83 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ie
84
85 %find_lang %{kfname}5 --with-qm --all-name --with-kde
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files -f %{kfname}5.lang
94 %defattr(644,root,root,755)
95 %doc README.md
96 %ghost %{_libdir}/libKF5I18n.so.5
97 %attr(755,root,root) %{_libdir}/libKF5I18n.so.*.*
98 %ghost %{_libdir}/libKF5I18nLocaleData.so.5
99 %attr(755,root,root) %{_libdir}/libKF5I18nLocaleData.so.5.*.*
100 %attr(755,root,root) %{qt5dir}/plugins/kf5/ktranscript.so
101 %{_datadir}/qlogging-categories5/ki18n.categories
102 %{_datadir}/qlogging-categories5/ki18n.renamecategories
103 %dir %{_libdir}/qt5/qml/org/kde/i18n
104 %dir %{_libdir}/qt5/qml/org/kde/i18n/localeData
105 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/i18n/localeData/libki18nlocaledataqmlplugin.so
106 %{_libdir}/qt5/qml/org/kde/i18n/localeData/qmldir
107
108 %files devel
109 %defattr(644,root,root,755)
110 %{_includedir}/KF5/KI18n
111 %{_includedir}/KF5/KI18nLocaleData
112 %{_libdir}/cmake/KF5I18n
113 %{_libdir}/libKF5I18n.so
114 %{_libdir}/libKF5I18nLocaleData.so
115 %{qt5dir}/mkspecs/modules/qt_KI18n.pri
This page took 0.155793 seconds and 4 git commands to generate.