]> git.pld-linux.org Git - packages/kf5-ki18n.git/blob - kf5-ki18n.spec
- we want absolute path; https://bugs.kde.org/show_bug.cgi?id=341719
[packages/kf5-ki18n.git] / kf5-ki18n.spec
1 # TODO:
2 # - dir /usr/include/KF5 not packaged
3 # /usr/lib/qt5/plugins/kf5 not packaged
4 # find_lang needs to be updated (to handle pmap, pmapc, js files)
5 %define         kdeframever     5.4
6 %define         qtver           5.3.2
7 %define         kfname          ki18n
8
9 Summary:        KDE Gettext-based UI text internationalization
10 Name:           kf5-%{kfname}
11 Version:        5.4.0
12 Release:        0.1
13 License:        LGPL v2.1+
14 Group:          X11/Libraries
15 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
16 # Source0-md5:  b340728a206fc4529f93ff73d2168b41
17 Patch0:         kf5-ki18n-absolute.patch
18 URL:            http://www.kde.org/
19 BuildRequires:  Qt5Concurrent-devel >= %{qtver}
20 BuildRequires:  Qt5Core-devel >= %{qtver}
21 BuildRequires:  Qt5Script-devel >= %{qtver}
22 BuildRequires:  Qt5Test-devel >= %{qtver}
23 BuildRequires:  cmake >= 2.8.12
24 BuildRequires:  gettext-devel
25 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
26 BuildRequires:  perl-base
27 BuildRequires:  rpmbuild(macros) >= 1.164
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         qt5dir          %{_libdir}/qt5
33
34 %description
35 KI18n provides functionality for internationalizing user interface
36 text in applications, based on the GNU Gettext translation system. It
37 wraps the standard Gettext functionality, so that the programmers and
38 translators can use the familiar Gettext tools and workflows.
39
40 KI18n provides additional functionality as well, for both programmers
41 and translators, which can help to achieve a higher overall quality of
42 source and translated text. This includes argument capturing,
43 customizable markup, and translation scripting.
44
45 %package devel
46 Summary:        Header files for %{kfname} development
47 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
48 Group:          X11/Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50
51 %description devel
52 Header files for %{kfname} development.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe dla programistów używających %{kfname}.
56
57 %prep
58 %setup -q -n %{kfname}-%{version}
59 %patch0 -p1
60
61 %build
62 install -d build
63 cd build
64 %cmake \
65         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
66         ../
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} -C build/ install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %find_lang %{kfname}5
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files -f %{kfname}5.lang
84 %defattr(644,root,root,755)
85 %doc README.md
86 %attr(755,root,root) %ghost %{_libdir}/libKF5I18n.so.5
87 %attr(755,root,root) %{_libdir}/libKF5I18n.so.5.4.0
88 %attr(755,root,root) %{qt5dir}/plugins/kf5/ktranscript.so
89
90 %files devel
91 %defattr(644,root,root,755)
92 %{_includedir}/KF5/KI18n
93 %{_includedir}/KF5/ki18n_version.h
94 %{_libdir}/cmake/KF5I18n
95 %attr(755,root,root) %{_libdir}/libKF5I18n.so
96 %{qt5dir}/mkspecs/modules/qt_KI18n.pri
This page took 0.081422 seconds and 3 git commands to generate.