]> git.pld-linux.org Git - packages/kf5-ki18n.git/blob - kf5-ki18n.spec
- Up to 5.65.0.
[packages/kf5-ki18n.git] / kf5-ki18n.spec
1 # TODO:
2 # find_lang needs to be updated (to handle pmap, pmapc, js files)
3 %define         kdeframever     5.65
4 %define         qtver           5.9.0
5 %define         kfname          ki18n
6
7 Summary:        KDE Gettext-based UI text internationalization
8 Name:           kf5-%{kfname}
9 Version:        5.65.0
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  89e847e45c19baca140ae68f8f7b7a14
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Concurrent-devel >= %{qtver}
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Script-devel >= %{qtver}
19 BuildRequires:  Qt5Test-devel >= %{qtver}
20 BuildRequires:  cmake >= 2.8.12
21 BuildRequires:  gettext-devel
22 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
23 BuildRequires:  ninja
24 BuildRequires:  perl-base
25 BuildRequires:  rpmbuild(macros) >= 1.164
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 Requires:       kf5-dirs
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         qt5dir          %{_libdir}/qt5
32
33 %description
34 KI18n provides functionality for internationalizing user interface
35 text in applications, based on the GNU Gettext translation system. It
36 wraps the standard Gettext functionality, so that the programmers and
37 translators can use the familiar Gettext tools and workflows.
38
39 KI18n provides additional functionality as well, for both programmers
40 and translators, which can help to achieve a higher overall quality of
41 source and translated text. This includes argument capturing,
42 customizable markup, and translation scripting.
43
44 %package devel
45 Summary:        Header files for %{kfname} development
46 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
47 Group:          X11/Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49
50 %description devel
51 Header files for %{kfname} development.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe dla programistów używających %{kfname}.
55
56 %prep
57 %setup -q -n %{kfname}-%{version}
58
59 %build
60 install -d build
61 cd build
62 %cmake -G Ninja \
63         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
64         ../
65 %ninja_build
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 %ninja_install -C build
70
71 %find_lang %{kfname}5 --with-qm --all-name --with-kde
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post -p /sbin/ldconfig
77 %postun -p /sbin/ldconfig
78
79 %files -f %{kfname}5.lang
80 %defattr(644,root,root,755)
81 %doc README.md
82 %attr(755,root,root) %ghost %{_libdir}/libKF5I18n.so.5
83 %attr(755,root,root) %{_libdir}/libKF5I18n.so.*.*
84 %attr(755,root,root) %{qt5dir}/plugins/kf5/ktranscript.so
85
86 %files devel
87 %defattr(644,root,root,755)
88 %{_includedir}/KF5/KI18n
89 %{_includedir}/KF5/ki18n_version.h
90 %{_libdir}/cmake/KF5I18n
91 %attr(755,root,root) %{_libdir}/libKF5I18n.so
92 %{qt5dir}/mkspecs/modules/qt_KI18n.pri
This page took 0.083315 seconds and 3 git commands to generate.