]> git.pld-linux.org Git - packages/kf5-ki18n.git/blob - kf5-ki18n.spec
- updated to 5.98.0
[packages/kf5-ki18n.git] / kf5-ki18n.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 # TODO:
5 # find_lang needs to be updated (to handle pmap, pmapc, js files)
6 %define         kdeframever     5.98
7 %define         qtver           5.15.2
8 %define         kfname          ki18n
9
10 Summary:        KDE Gettext-based UI text internationalization
11 Name:           kf5-%{kfname}
12 Version:        5.98.0
13 Release:        1
14 License:        LGPL v2.1+
15 Group:          X11/Libraries
16 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
17 # Source0-md5:  dc8c646da4963fdfb59f735f124e2ae8
18 URL:            http://www.kde.org/
19 BuildRequires:  Qt5Concurrent-devel >= %{qtver}
20 BuildRequires:  Qt5Core-devel >= %{qtver}
21 BuildRequires:  Qt5Qml-devel >= %{qtver}
22 BuildRequires:  Qt5Test-devel >= %{qtver}
23 BuildRequires:  cmake >= 3.16
24 BuildRequires:  kf5-extra-cmake-modules >= %{version}
25 BuildRequires:  ninja
26 BuildRequires:  python3
27 BuildRequires:  rpmbuild(macros) >= 1.736
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 Requires:       Qt5Core >= %{qtver}
31 Requires:       Qt5Qml >= %{qtver}
32 Requires:       kf5-dirs
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         qt5dir          %{_libdir}/qt5
36
37 %description
38 KI18n provides functionality for internationalizing user interface
39 text in applications, based on the GNU Gettext translation system. It
40 wraps the standard Gettext functionality, so that the programmers and
41 translators can use the familiar Gettext tools and workflows.
42
43 KI18n provides additional functionality as well, for both programmers
44 and translators, which can help to achieve a higher overall quality of
45 source and translated text. This includes argument capturing,
46 customizable markup, and translation scripting.
47
48 %package devel
49 Summary:        Header files for %{kfname} development
50 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
51 Group:          X11/Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       cmake >= 3.16
54 Requires:       gettext-tools
55
56 %description devel
57 Header files for %{kfname} development.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe dla programistów używających %{kfname}.
61
62 %prep
63 %setup -q -n %{kfname}-%{version}
64
65 %build
66 install -d build
67 cd build
68 %cmake -G Ninja \
69         %{!?with_tests:-DBUILD_TESTING=OFF} \
70         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
71         ../
72 %ninja_build
73
74 %if %{with tests}
75 ctest
76 %endif
77
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 %ninja_install -C build
82
83 %find_lang %{kfname}5 --with-qm --all-name --with-kde
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post -p /sbin/ldconfig
89 %postun -p /sbin/ldconfig
90
91 %files -f %{kfname}5.lang
92 %defattr(644,root,root,755)
93 %doc README.md
94 %ghost %{_libdir}/libKF5I18n.so.5
95 %attr(755,root,root) %{_libdir}/libKF5I18n.so.*.*
96 %ghost %{_libdir}/libKF5I18nLocaleData.so.5
97 %attr(755,root,root) %{_libdir}/libKF5I18nLocaleData.so.5.*.*
98 %attr(755,root,root) %{qt5dir}/plugins/kf5/ktranscript.so
99 %{_datadir}/qlogging-categories5/ki18n.categories
100 %{_datadir}/qlogging-categories5/ki18n.renamecategories
101 %dir %{_libdir}/qt5/qml/org/kde/i18n
102 %dir %{_libdir}/qt5/qml/org/kde/i18n/localeData
103 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/i18n/localeData/libki18nlocaledataqmlplugin.so
104 %{_libdir}/qt5/qml/org/kde/i18n/localeData/qmldir
105
106 %files devel
107 %defattr(644,root,root,755)
108 %{_includedir}/KF5/KI18n
109 %{_includedir}/KF5/KI18nLocaleData
110 %{_libdir}/cmake/KF5I18n
111 %{_libdir}/libKF5I18n.so
112 %{_libdir}/libKF5I18nLocaleData.so
113 %{qt5dir}/mkspecs/modules/qt_KI18n.pri
This page took 0.056678 seconds and 3 git commands to generate.