]> git.pld-linux.org Git - packages/kf5-kguiaddons.git/blob - kf5-kguiaddons.spec
- updated to 5.98.0
[packages/kf5-kguiaddons.git] / kf5-kguiaddons.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeframever     5.98
5 %define         qtver           5.15.2
6 %define         kfname          kguiaddons
7
8 Summary:        Utilities for graphical user interfaces
9 Name:           kf5-%{kfname}
10 Version:        5.98.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  f6d58f99f68791cb7a3ec3f386707ba4
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel >= %{qtver}
19 BuildRequires:  Qt5Test-devel >= %{qtver}
20 BuildRequires:  Qt5WaylandClient >= %{qtver}
21 BuildRequires:  Qt5WaylandClient-devel >= %{qtver}
22 BuildRequires:  Qt5X11Extras-devel >= %{qtver}
23 BuildRequires:  cmake >= 3.16
24 BuildRequires:  kf5-extra-cmake-modules >= %{version}
25 BuildRequires:  kf5-plasma-wayland-protocols-devel >= 1.7.0
26 BuildRequires:  libxcb-devel
27 BuildRequires:  ninja
28 BuildRequires:  pkgconfig
29 BuildRequires:  qt5-linguist >= %{qtver}
30 BuildRequires:  rpmbuild(macros) >= 1.736
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  wayland-devel >= 1.9
33 BuildRequires:  xorg-lib-libX11-devel
34 BuildRequires:  xorg-proto-kbproto-devel
35 BuildRequires:  xz
36 Requires:       Qt5Gui >= %{qtver}
37 Requires:       Qt5WaylandClient >= %{qtver}
38 Requires:       Qt5X11Extras >= %{qtver}
39 Requires:       kf5-dirs
40 Requires:       wayland >= 1.9
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         qt5dir          %{_libdir}/qt5
44
45 %description
46 The KDE GUI addons provide utilities for graphical user interfaces in
47 the areas of colors, fonts, text, images, keyboard input.
48
49 %package devel
50 Summary:        Header files for %{kfname} development
51 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
52 Group:          X11/Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       Qt5Gui-devel >= %{qtver}
55 Requires:       cmake >= 3.16
56
57 %description devel
58 Header files for %{kfname} development.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe dla programistów używających %{kfname}.
62
63 %prep
64 %setup -q -n %{kfname}-%{version}
65
66 %build
67 install -d build
68 cd build
69 %cmake -G Ninja \
70         %{!?with_tests:-DBUILD_TESTING=OFF} \
71         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
72         ../
73 %ninja_build
74
75 %if %{with tests}
76 ctest
77 %endif
78
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 %ninja_install -C build
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc README.md
93 %ghost %{_libdir}/libKF5GuiAddons.so.5
94 %attr(755,root,root) %{_libdir}/libKF5GuiAddons.so.*.*
95 %{_datadir}/qlogging-categories5/kguiaddons.categories
96 %attr(755,root,root) %{_bindir}/kde-geo-uri-handler
97 %{_desktopdir}/google-maps-geo-handler.desktop
98 %{_desktopdir}/openstreetmap-geo-handler.desktop
99 %{_desktopdir}/qwant-maps-geo-handler.desktop
100 %{_desktopdir}/wheelmap-geo-handler.desktop
101
102 %files devel
103 %defattr(644,root,root,755)
104 %{_includedir}/KF5/KGuiAddons
105 %{_libdir}/cmake/KF5GuiAddons
106 %{_libdir}/libKF5GuiAddons.so
107 %{qt5dir}/mkspecs/modules/qt_KGuiAddons.pri
This page took 0.082313 seconds and 3 git commands to generate.