]> git.pld-linux.org Git - packages/kf5-kglobalaccel.git/blob - kf5-kglobalaccel.spec
tar.xz deps
[packages/kf5-kglobalaccel.git] / kf5-kglobalaccel.spec
1 # TODO:
2 # - dir /usr/include/KF5 not packaged
3 %define         _state          stable
4 %define         orgname         kglobalaccel
5
6 Summary:        Global desktop keyboard shortcuts
7 Name:           kf5-%{orgname}
8 Version:        5.0.0
9 Release:        0.1
10 License:        LGPL v2.1+
11 Group:          X11/Libraries
12 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
13 # Source0-md5:  2789a7e598942a9a7004fa867019ec6a
14 URL:            http://www.kde.org/
15 BuildRequires:  Qt5Core-devel
16 BuildRequires:  Qt5DBus-devel
17 BuildRequires:  Qt5Gui-devel >= 5.3.1
18 BuildRequires:  Qt5Test-devel
19 BuildRequires:  Qt5Widgets-devel
20 BuildRequires:  Qt5X11Extras-devel
21 BuildRequires:  Qt5Xml-devel >= 5.2.0
22 BuildRequires:  cmake >= 2.8.12
23 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
24 BuildRequires:  qt5-linguist
25 BuildRequires:  rpmbuild(macros) >= 1.164
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         qt5dir          %{_libdir}/qt5
31
32 %description
33 KGlobalAccel allows you to have global accelerators that are
34 independent of the focused window. Unlike regular shortcuts, the
35 application's window does not need focus for them to be activated.
36
37 %package devel
38 Summary:        Header files for %{orgname} development
39 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{orgname}
40 Group:          X11/Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 Header files for %{orgname} development.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe dla programistów używających %{orgname}.
48
49 %prep
50 %setup -q -n %{orgname}-%{version}
51
52 %build
53 install -d build
54 cd build
55 %cmake \
56         -DBIN_INSTALL_DIR=%{_bindir} \
57         -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
58         -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
59         -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
60         -DQML_INSTALL_DIR=%{qt5dir}/qml \
61         -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
62         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
63         -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
64         -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
65         -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
66         -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
67         ../
68 %{__make}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} -C build/ install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 %find_lang %{orgname}5_qt --with-qm
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files -f %{orgname}5_qt.lang
85 %defattr(644,root,root,755)
86 %doc README.md
87 %attr(755,root,root) %ghost %{_libdir}/libKF5GlobalAccel.so.5
88 %attr(755,root,root) %{_libdir}/libKF5GlobalAccel.so.5.0.0
89 %{_datadir}/dbus-1/interfaces/kf5_org.kde.KGlobalAccel.xml
90 %{_datadir}/dbus-1/interfaces/kf5_org.kde.kglobalaccel.Component.xml
91
92 %files devel
93 %defattr(644,root,root,755)
94 %{_includedir}/KF5/KGlobalAccel
95 %{_includedir}/KF5/kglobalaccel_version.h
96 %{_libdir}/cmake/KF5GlobalAccel
97 %attr(755,root,root) %{_libdir}/libKF5GlobalAccel.so
98 %{qt5dir}/mkspecs/modules/qt_KGlobalAccel.pri
This page took 0.058304 seconds and 3 git commands to generate.