]> git.pld-linux.org Git - packages/kf5-kdoctools.git/blob - kf5-kdoctools.spec
a68a1d5cc02f2ee6b3d893ca0a9348de224a9ac5
[packages/kf5-kdoctools.git] / kf5-kdoctools.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 # TODO:
5 # - runtime Requires if any
6 # - package manual pages
7 %define         kdeframever     5.97
8 %define         qtver           5.15.2
9 %define         kfname          kdoctools
10
11 Summary:        Create documentation from DocBook
12 Name:           kf5-%{kfname}
13 Version:        5.97.0
14 Release:        2
15 License:        GPL v2+/LGPL v2.1+
16 Group:          X11/Libraries
17 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
18 # Source0-md5:  76db6e9f9200fad4b9cbc3b01ae3755f
19 URL:            http://www.kde.org/
20 BuildRequires:  Qt5Core-devel >= %{qtver}
21 BuildRequires:  cmake >= 3.16
22 BuildRequires:  docbook-dtd45-xml
23 BuildRequires:  docbook-style-xsl
24 BuildRequires:  kf5-extra-cmake-modules >= %{version}
25 BuildRequires:  kf5-karchive-devel >= %{version}
26 BuildRequires:  kf5-ki18n-devel >= %{version}
27 BuildRequires:  libxml2-devel
28 BuildRequires:  libxml2-progs
29 BuildRequires:  libxslt-devel
30 BuildRequires:  ninja
31 BuildRequires:  perl-URI
32 BuildRequires:  perl-base
33 BuildRequires:  qt5-linguist >= %{qtver}
34 BuildRequires:  rpmbuild(macros) >= 1.736
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xz
37 Requires:       Qt5Core >= %{qtver}
38 Requires:       docbook-style-xsl
39 Requires:       kf5-dirs
40 Requires:       kf5-karchive >= %{version}
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         qt5dir          %{_libdir}/qt5
44
45 %description
46 Provides tools to generate documentation in various format from
47 DocBook files.
48
49 %package devel
50 Summary:        Header files for %{kfname} development
51 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
52 Group:          X11/Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       Qt5Core-devel >= %{qtver}
55 Requires:       cmake >= 3.16
56
57 %description devel
58 Header files for %{kfname} development.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe dla programistów używających %{kfname}.
62
63 %prep
64 %setup -q -n %{kfname}-%{version}
65
66 %build
67 install -d build
68 cd build
69 %cmake -G Ninja \
70         %{!?with_tests:-DBUILD_TESTING=OFF} \
71         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
72         ../
73 %ninja_build
74
75 %if %{with tests}
76 ctest
77 %endif
78
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 %ninja_install -C build
83
84 %find_lang %{kfname}5
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post -p /sbin/ldconfig
90 %postun -p /sbin/ldconfig
91
92 %files -f %{kfname}5.lang
93 %defattr(644,root,root,755)
94 %doc README.md
95 %attr(755,root,root) %{_bindir}/checkXML5
96 %attr(755,root,root) %{_bindir}/meinproc5
97 %ghost %{_libdir}/libKF5DocTools.so.5
98 %attr(755,root,root) %{_libdir}/libKF5DocTools.so.*.*
99 %{_docdir}/HTML/*/kdoctools5-common
100 %dir %{_datadir}/kf5/kdoctools
101 %{_datadir}/kf5/kdoctools/customization
102 %{_mandir}/man1/checkXML5.1*
103 %{_mandir}/man1/meinproc5.1*
104 %{_mandir}/man7/kf5options.7*
105 %{_mandir}/man7/qt5options.7*
106 %lang(ca) %{_mandir}/ca/man1/checkXML5.1*
107 %lang(ca) %{_mandir}/ca/man1/meinproc5.1*
108 %lang(ca) %{_mandir}/ca/man7/kf5options.7*
109 %lang(ca) %{_mandir}/ca/man7/qt5options.7*
110 %lang(de) %{_mandir}/de/man1/checkXML5.1*
111 %lang(de) %{_mandir}/de/man1/meinproc5.1*
112 %lang(de) %{_mandir}/de/man7/kf5options.7*
113 %lang(de) %{_mandir}/de/man7/qt5options.7*
114 %lang(es) %{_mandir}/es/man1/checkXML5.1*
115 %lang(es) %{_mandir}/es/man1/meinproc5.1*
116 %lang(es) %{_mandir}/es/man7/kf5options.7*
117 %lang(es) %{_mandir}/es/man7/qt5options.7*
118 %lang(it) %{_mandir}/id/man1/checkXML5.1*
119 %lang(it) %{_mandir}/it/man1/checkXML5.1*
120 %lang(it) %{_mandir}/it/man1/meinproc5.1*
121 %lang(it) %{_mandir}/it/man7/kf5options.7*
122 %lang(it) %{_mandir}/it/man7/qt5options.7*
123 %lang(nl) %{_mandir}/nl/man1/checkXML5.1*
124 %lang(nl) %{_mandir}/nl/man1/meinproc5.1*
125 %lang(nl) %{_mandir}/nl/man7/kf5options.7*
126 %lang(nl) %{_mandir}/nl/man7/qt5options.7*
127 %lang(pt) %{_mandir}/pt/man1/checkXML5.1*
128 %lang(pt) %{_mandir}/pt/man1/meinproc5.1*
129 %lang(pt) %{_mandir}/pt/man7/kf5options.7*
130 %lang(pt) %{_mandir}/pt/man7/qt5options.7*
131 %lang(pt_BR) %{_mandir}/pt_BR/man1/checkXML5.1*
132 %lang(pt_BR) %{_mandir}/pt_BR/man1/meinproc5.1*
133 %lang(pt_BR) %{_mandir}/pt_BR/man7/kf5options.7*
134 %lang(pt_BR) %{_mandir}/pt_BR/man7/qt5options.7*
135 %lang(ru) %{_mandir}/ru/man1/checkXML5.1*
136 %lang(ru) %{_mandir}/ru/man7/qt5options.7*
137 %lang(sv) %{_mandir}/sv/man1/checkXML5.1*
138 %lang(sv) %{_mandir}/sv/man1/meinproc5.1*
139 %lang(sv) %{_mandir}/sv/man7/kf5options.7*
140 %lang(sv) %{_mandir}/sv/man7/qt5options.7*
141 %lang(uk) %{_mandir}/uk/man1/checkXML5.1*
142 %lang(uk) %{_mandir}/uk/man1/meinproc5.1*
143 %lang(uk) %{_mandir}/uk/man7/kf5options.7*
144 %lang(uk) %{_mandir}/uk/man7/qt5options.7*
145
146 %files devel
147 %defattr(644,root,root,755)
148 %{_includedir}/KF5/KDocTools
149 %{_libdir}/cmake/KF5DocTools
150 %{_libdir}/libKF5DocTools.so
This page took 0.084549 seconds and 2 git commands to generate.