]> git.pld-linux.org Git - packages/kf5-kdoctools.git/blob - kf5-kdoctools.spec
- updated to 5.91.0
[packages/kf5-kdoctools.git] / kf5-kdoctools.spec
1 # TODO:
2 # - runtime Requires if any
3 # - package manual pages
4 %define         kdeframever     5.91
5 %define         qtver           5.15.2
6 %define         kfname          kdoctools
7
8 Summary:        Create documentation from DocBook
9 Name:           kf5-%{kfname}
10 Version:        5.91.0
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  f49f6f134a370add0e901aae468c2164
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  cmake >= 3.16
19 BuildRequires:  docbook-dtd45-xml
20 BuildRequires:  docbook-style-xsl
21 BuildRequires:  kf5-extra-cmake-modules >= %{version}
22 BuildRequires:  kf5-karchive-devel >= %{version}
23 BuildRequires:  kf5-ki18n-devel >= %{version}
24 BuildRequires:  libxml2-devel
25 BuildRequires:  libxml2-progs
26 BuildRequires:  libxslt-devel
27 BuildRequires:  ninja
28 BuildRequires:  perl-URI
29 BuildRequires:  perl-base
30 BuildRequires:  qt5-linguist >= %{qtver}
31 BuildRequires:  rpmbuild(macros) >= 1.736
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 Requires:       Qt5Core >= %{qtver}
35 Requires:       kf5-dirs
36 Requires:       kf5-karchive >= %{version}
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         qt5dir          %{_libdir}/qt5
40
41 %description
42 Provides tools to generate documentation in various format from
43 DocBook files.
44
45 %package devel
46 Summary:        Header files for %{kfname} development
47 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
48 Group:          X11/Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       Qt5Core-devel >= %{qtver}
51 Requires:       cmake >= 3.16
52
53 %description devel
54 Header files for %{kfname} development.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe dla programistów używających %{kfname}.
58
59 %prep
60 %setup -q -n %{kfname}-%{version}
61
62 %build
63 install -d build
64 cd build
65 %cmake -G Ninja \
66         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
67         ../
68 %ninja_build
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 %ninja_install -C build
73
74 %find_lang %{kfname}5
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files -f %{kfname}5.lang
83 %defattr(644,root,root,755)
84 %doc README.md
85 %attr(755,root,root) %{_bindir}/checkXML5
86 %attr(755,root,root) %{_bindir}/meinproc5
87 %ghost %{_libdir}/libKF5DocTools.so.5
88 %attr(755,root,root) %{_libdir}/libKF5DocTools.so.*.*
89 %{_docdir}/HTML/*/kdoctools5-common
90 %dir %{_datadir}/kf5/kdoctools
91 %{_datadir}/kf5/kdoctools/customization
92 %{_mandir}/man1/checkXML5.1*
93 %{_mandir}/man1/meinproc5.1*
94 %{_mandir}/man7/kf5options.7*
95 %{_mandir}/man7/qt5options.7*
96 %lang(ca) %{_mandir}/ca/man1/checkXML5.1*
97 %lang(ca) %{_mandir}/ca/man1/meinproc5.1*
98 %lang(ca) %{_mandir}/ca/man7/kf5options.7*
99 %lang(ca) %{_mandir}/ca/man7/qt5options.7*
100 %lang(de) %{_mandir}/de/man1/checkXML5.1*
101 %lang(de) %{_mandir}/de/man1/meinproc5.1*
102 %lang(de) %{_mandir}/de/man7/kf5options.7*
103 %lang(de) %{_mandir}/de/man7/qt5options.7*
104 %lang(es) %{_mandir}/es/man1/checkXML5.1*
105 %lang(es) %{_mandir}/es/man1/meinproc5.1*
106 %lang(es) %{_mandir}/es/man7/kf5options.7*
107 %lang(es) %{_mandir}/es/man7/qt5options.7*
108 %lang(it) %{_mandir}/id/man1/checkXML5.1*
109 %lang(it) %{_mandir}/it/man1/checkXML5.1*
110 %lang(it) %{_mandir}/it/man1/meinproc5.1*
111 %lang(it) %{_mandir}/it/man7/kf5options.7*
112 %lang(it) %{_mandir}/it/man7/qt5options.7*
113 %lang(nl) %{_mandir}/nl/man1/checkXML5.1*
114 %lang(nl) %{_mandir}/nl/man1/meinproc5.1*
115 %lang(nl) %{_mandir}/nl/man7/kf5options.7*
116 %lang(nl) %{_mandir}/nl/man7/qt5options.7*
117 %lang(pt) %{_mandir}/pt/man1/checkXML5.1*
118 %lang(pt) %{_mandir}/pt/man1/meinproc5.1*
119 %lang(pt) %{_mandir}/pt/man7/kf5options.7*
120 %lang(pt) %{_mandir}/pt/man7/qt5options.7*
121 %lang(pt_BR) %{_mandir}/pt_BR/man1/checkXML5.1*
122 %lang(pt_BR) %{_mandir}/pt_BR/man1/meinproc5.1*
123 %lang(pt_BR) %{_mandir}/pt_BR/man7/kf5options.7*
124 %lang(pt_BR) %{_mandir}/pt_BR/man7/qt5options.7*
125 %lang(ru) %{_mandir}/ru/man1/checkXML5.1*
126 %lang(ru) %{_mandir}/ru/man7/qt5options.7*
127 %lang(sv) %{_mandir}/sv/man1/checkXML5.1*
128 %lang(sv) %{_mandir}/sv/man1/meinproc5.1*
129 %lang(sv) %{_mandir}/sv/man7/kf5options.7*
130 %lang(sv) %{_mandir}/sv/man7/qt5options.7*
131 %lang(uk) %{_mandir}/uk/man1/checkXML5.1*
132 %lang(uk) %{_mandir}/uk/man1/meinproc5.1*
133 %lang(uk) %{_mandir}/uk/man7/kf5options.7*
134 %lang(uk) %{_mandir}/uk/man7/qt5options.7*
135
136 %files devel
137 %defattr(644,root,root,755)
138 %{_includedir}/KF5/KDocTools
139 %{_libdir}/cmake/KF5DocTools
140 %{_libdir}/libKF5DocTools.so
This page took 0.072748 seconds and 3 git commands to generate.