]> git.pld-linux.org Git - packages/kf5-kcrash.git/blob - kf5-kcrash.spec
- up to 5.4.0
[packages/kf5-kcrash.git] / kf5-kcrash.spec
1 # TODO:
2 # - runtime Requires if any
3 # - these dirs are not own by any package
4 #  /usr/include/KF5
5 #  /usr/share/kf5
6 %define         kdeframever     5.4
7 %define         qtver           5.3.2
8 %define         kfname          kcrash
9
10 Summary:        Graceful handling of application crashes
11 Name:           kf5-%{kfname}
12 Version:        5.4.0
13 Release:        0.1
14 License:        GPL v2+/LGPL v2.1+
15 Group:          X11/Libraries
16 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
17 # Source0-md5:  971649d12a57cf1c05c77fb3c4370aea
18 URL:            http://www.kde.org/
19 BuildRequires:  Qt5Core-devel >= %{qtver}
20 BuildRequires:  Qt5DBus-devel >= %{qtver}
21 BuildRequires:  Qt5Gui-devel >= %{qtver}
22 BuildRequires:  Qt5Test-devel >= %{qtver}
23 BuildRequires:  Qt5Widgets-devel >= %{qtver}
24 BuildRequires:  Qt5X11Extras-devel >= %{qtver}
25 BuildRequires:  cmake >= 2.8.12
26 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
27 BuildRequires:  kf5-kcoreaddons-devel >= %{version}
28 BuildRequires:  kf5-kwindowsystem-devel >= %{version}
29 BuildRequires:  polkit-qt-1-devel
30 BuildRequires:  qt5-linguist >= %{qtver}
31 BuildRequires:  rpmbuild(macros) >= 1.164
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         qt5dir          %{_libdir}/qt5
37
38 %description
39 KCrash provides support for intercepting and handling application
40 crashes.
41
42 %package devel
43 Summary:        Header files for %{kfname} development
44 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
45 Group:          X11/Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47
48 %description devel
49 Header files for %{kfname} development.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe dla programistów używających %{kfname}.
53
54 %prep
55 %setup -q -n %{kfname}-%{version}
56
57 %build
58 install -d build
59 cd build
60 %cmake \
61         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
62         ../
63 %{__make}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} -C build/ install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post -p /sbin/ldconfig
75 %postun -p /sbin/ldconfig
76
77 %files
78 %defattr(644,root,root,755)
79 %doc README.md
80 %attr(755,root,root) %ghost %{_libdir}/libKF5Crash.so.5
81 %attr(755,root,root) %{_libdir}/libKF5Crash.so.5.4.0
82
83 %files devel
84 %defattr(644,root,root,755)
85 %{_includedir}/KF5/KCrash
86 %{_includedir}/KF5/kcrash_version.h
87 %{_libdir}/cmake/KF5Crash
88 %attr(755,root,root) %{_libdir}/libKF5Crash.so
89 %{qt5dir}/mkspecs/modules/qt_KCrash.pri
This page took 0.432195 seconds and 3 git commands to generate.