]> git.pld-linux.org Git - packages/kf5-kcoreaddons.git/blob - kf5-kcoreaddons.spec
- cmake macro sets bin dir now
[packages/kf5-kcoreaddons.git] / kf5-kcoreaddons.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 # TODO:
6 # - runtime Requires if any
7 # - dir /usr/include/KF5 not packaged
8
9 %define         kdeframever     5.4
10 %define         qtver           5.3.2
11 %define         kfname          kcoreaddons
12 Summary:        Utilities for core application functionality and accessing the OS
13 Name:           kf5-%{kfname}
14 Version:        5.4.0
15 Release:        1
16 License:        GPL v2+/LGPL v2.1+
17 Group:          X11/Libraries
18 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
19 # Source0-md5:  4946f5145126de7bf293c3140194e966
20 URL:            http://www.kde.org/
21 BuildRequires:  Qt5Core-devel >= %{qtver}
22 BuildRequires:  Qt5Test-devel >= %{qtver}
23 BuildRequires:  cmake >= 2.8.12
24 BuildRequires:  fam-devel
25 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
26 BuildRequires:  qt5-linguist >= %{qtver}
27 BuildRequires:  rpmbuild(macros) >= 1.164
28 BuildRequires:  shared-mime-info
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 KCoreAddons provides classes built on top of QtCore to perform various
35 tasks such as manipulating mime types, autosaving files, creating
36 backup files, generating random sequences, performing text
37 manipulations such as macro replacement, accessing user information
38 and many more.
39
40 %package devel
41 Summary:        Header files for %{kfname} development
42 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
43 Group:          X11/Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description devel
47 Header files for %{kfname} development.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe dla programistów używających %{kfname}.
51
52 %prep
53 %setup -q -n %{kfname}-%{version}
54
55 %build
56 install -d build
57 cd build
58 %cmake \
59         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
60         ../
61 %{__make}
62
63 %{?with_tests:%{__make} test}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 %{__make} -C build install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %find_lang %{kfname}5_qt --with-qm
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post   -p /sbin/ldconfig
76 %postun -p /sbin/ldconfig
77
78 %files -f %{kfname}5_qt.lang
79 %defattr(644,root,root,755)
80 %doc README.md
81 %{_datadir}/mime/packages/kde5.xml
82 %attr(755,root,root) %{_libdir}/libKF5CoreAddons.so.*.*.*
83 %attr(755,root,root) %ghost %{_libdir}/libKF5CoreAddons.so.5
84
85 %files devel
86 %defattr(644,root,root,755)
87 %attr(755,root,root) %{_bindir}/desktoptojson
88 %{_includedir}/KF5/KCoreAddons
89 %{_includedir}/KF5/kcoreaddons_version.h
90 %{_libdir}/cmake/KF5CoreAddons
91 %attr(755,root,root) %{_libdir}/libKF5CoreAddons.so
92 %{_libdir}/qt5/mkspecs/modules/qt_KCoreAddons.pri
This page took 0.037578 seconds and 3 git commands to generate.