]> git.pld-linux.org Git - packages/kf5-kcontacts.git/blob - kf5-kcontacts.spec
- updated to 5.100.0
[packages/kf5-kcontacts.git] / kf5-kcontacts.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeframever     5.100
5 %define         qtver           5.15.2
6 %define         kfname          kcontacts
7 Summary:        kcontacts
8 Name:           kf5-%{kfname}
9 Version:        5.100.0
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  7f1a0248fb3065f6476693ce929aedf2
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Gui-devel
18 BuildRequires:  Qt5Test-devel >= %{qtver}
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  gettext-devel
21 BuildRequires:  kf5-extra-cmake-modules >= %{version}
22 BuildRequires:  kf5-kcodecs-devel >= %{version}
23 BuildRequires:  kf5-kconfig-devel >= %{version}
24 BuildRequires:  kf5-kcoreaddons-devel >= %{version}
25 BuildRequires:  kf5-ki18n-devel >= %{version}
26 BuildRequires:  ninja
27 BuildRequires:  qt5-build >= %{qtver}
28 BuildRequires:  rpmbuild(macros) >= 1.164
29 BuildRequires:  shared-mime-info
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xz
32 Obsoletes:      ka5-kcontacts < 20.12.3
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Address book API based on KDE Frameworks.
37
38 %package devel
39 Summary:        Header files for %{kaname} development
40 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kaname}
41 Group:          X11/Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Obsoletes:      ka5-kcontacts-devel < 20.12.3
44
45 %description devel
46 Header files for %{kfname} development.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe dla programistów używających %{kaname}.
50
51
52 %prep
53 %setup -q -n %{kfname}-%{version}
54
55 %build
56 install -d build
57 cd build
58 %cmake -G Ninja \
59         %{!?with_tests:-DBUILD_TESTING=OFF} \
60         -DHTML_INSTALL_DIR=%{_kdedocdir} \
61         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
62         ..
63 %ninja_build
64
65 %if %{with tests}
66 ctest
67 %endif
68
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 %ninja_install -C build
73
74 %find_lang %{kaname} --all-name --with-kde
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post   -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files -f %{kaname}.lang
83 %defattr(644,root,root,755)
84 %{_datadir}/qlogging-categories5/kcontacts.categories
85 %{_datadir}/qlogging-categories5/kcontacts.renamecategories
86 %ghost %{_libdir}/libKF5Contacts.so.5
87 %{_libdir}/libKF5Contacts.so.5.*.*
88 #%%{_datadir}/kf5/kcontacts
89
90 %files devel
91 %defattr(644,root,root,755)
92 %{_includedir}/KF5/KContacts
93 %{_libdir}/cmake/KF5Contacts
94 %{_libdir}/libKF5Contacts.so
95 %{_libdir}/qt5/mkspecs/modules/qt_KContacts.pri
This page took 0.139867 seconds and 3 git commands to generate.