]> git.pld-linux.org Git - packages/kf5-kconfig.git/blob - kf5-kconfig.spec
a431892ec6134668bc9c308bc4831c3680096a2f
[packages/kf5-kconfig.git] / kf5-kconfig.spec
1 %define         kdeframever     5.24
2 %define         qtver           5.3.2
3 %define         kfname          kconfig
4
5 Summary:        Backend for storing application configuration
6 Name:           kf5-%{kfname}
7 Version:        5.24.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  e048b0684cbeba42a0d68461dd1bf3a9
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  Qt5Gui-devel >= %{qtver}
16 BuildRequires:  Qt5Test-devel >= %{qtver}
17 BuildRequires:  Qt5Xml-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
20 BuildRequires:  qt5-linguist >= %{qtver}
21 BuildRequires:  rpmbuild(macros) >= 1.164
22 BuildRequires:  tar >= 1:1.22
23 BuildRequires:  xz
24 Requires:       kf5-dirs
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         qt5dir          %{_libdir}/qt5
28
29 %description
30 KConfig provides an advanced configuration system. It is made of two
31 parts: KConfigCore and KConfigGui.
32
33 KConfigCore provides access to the configuration files themselves. It
34 features:
35
36 - Code generation: describe your configuration in an XML file, and use
37   `kconfig_compiler to generate classes that read and write
38   configuration entries.
39 - Cascading configuration files (global settings overridden by local
40   settings).
41 - Optional shell expansion support (see [docs/options.md](@ref
42   options)).
43 - The ability to lock down configuration options (see
44   [docs/options.md](@ref options)).
45
46 KConfigGui provides a way to hook widgets to the configuration so that
47 they are automatically initialized from the configuration and
48 automatically propagate their changes to their respective
49 configuration files.
50
51 %package devel
52 Summary:        Header files for %{kfname} development
53 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
54 Group:          X11/Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56
57 %description devel
58 Header files for %{kfname} development.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe dla programistów używających %{kfname}.
62
63 %prep
64 %setup -q -n %{kfname}-%{version}
65
66 %build
67 install -d build
68 cd build
69 %cmake \
70         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
71         ../
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT%{_datadir}/kconf_update
77
78 %{__make} -C build/ install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files -f %{kfname}5_qt.lang
90 %defattr(644,root,root,755)
91 %doc DESIGN README.md TODO
92 %attr(755,root,root) %ghost %{_libdir}/libKF5ConfigCore.so.5
93 %attr(755,root,root) %{_libdir}/libKF5ConfigCore.so.*.*
94 %attr(755,root,root) %ghost %{_libdir}/libKF5ConfigGui.so.5
95 %attr(755,root,root) %{_libdir}/libKF5ConfigGui.so.*.*
96 %attr(755,root,root) %{_bindir}/kreadconfig5
97 %attr(755,root,root) %{_bindir}/kwriteconfig5
98 %attr(755,root,root) %{_libdir}/kf5/kconf_update
99 %attr(755,root,root) %{_libdir}/kf5/kconfig_compiler_kf5
100 %dir %{_datadir}/kconf_update
101
102 %files devel
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_libdir}/libKF5ConfigCore.so
105 %attr(755,root,root) %{_libdir}/libKF5ConfigGui.so
106 %{_includedir}/KF5/KConfigCore
107 %{_includedir}/KF5/KConfigGui
108 %{_includedir}/KF5/kconfig_version.h
109 %{_libdir}/cmake/KF5Config
110 %{qt5dir}/mkspecs/modules/qt_KConfigCore.pri
111 %{qt5dir}/mkspecs/modules/qt_KConfigGui.pri
This page took 0.030982 seconds and 3 git commands to generate.