]> git.pld-linux.org Git - packages/kf5-kconfig.git/blob - kf5-kconfig.spec
- package directory for kconf_update files
[packages/kf5-kconfig.git] / kf5-kconfig.spec
1 %define         kdeframever     5.19
2 %define         qtver           5.3.2
3 %define         kfname          kconfig
4
5 Summary:        Backend for storing application configuration
6 Name:           kf5-%{kfname}
7 Version:        5.19.0
8 Release:        2
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  79953233cd7d507f4f8394bf62e23078
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  Qt5Gui-devel >= %{qtver}
16 BuildRequires:  Qt5Test-devel >= %{qtver}
17 BuildRequires:  Qt5Xml-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
20 BuildRequires:  qt5-linguist >= %{qtver}
21 BuildRequires:  rpmbuild(macros) >= 1.164
22 BuildRequires:  tar >= 1:1.22
23 BuildRequires:  xz
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         qt5dir          %{_libdir}/qt5
27
28 %description
29 KConfig provides an advanced configuration system. It is made of two
30 parts: KConfigCore and KConfigGui.
31
32 KConfigCore provides access to the configuration files themselves. It
33 features:
34
35 - Code generation: describe your configuration in an XML file, and use
36   `kconfig_compiler to generate classes that read and write
37   configuration entries.
38 - Cascading configuration files (global settings overridden by local
39   settings).
40 - Optional shell expansion support (see [docs/options.md](@ref
41   options)).
42 - The ability to lock down configuration options (see
43   [docs/options.md](@ref options)).
44
45 KConfigGui provides a way to hook widgets to the configuration so that
46 they are automatically initialized from the configuration and
47 automatically propagate their changes to their respective
48 configuration files.
49
50 %package devel
51 Summary:        Header files for %{kfname} development
52 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
53 Group:          X11/Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55
56 %description devel
57 Header files for %{kfname} development.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe dla programistów używających %{kfname}.
61
62 %prep
63 %setup -q -n %{kfname}-%{version}
64
65 %build
66 install -d build
67 cd build
68 %cmake \
69         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
70         ../
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT%{_datadir}/kconf_update
76
77 %{__make} -C build/ install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post -p /sbin/ldconfig
86 %postun -p /sbin/ldconfig
87
88 %files -f %{kfname}5_qt.lang
89 %defattr(644,root,root,755)
90 %doc DESIGN README.md TODO
91 %attr(755,root,root) %ghost %{_libdir}/libKF5ConfigCore.so.5
92 %attr(755,root,root) %{_libdir}/libKF5ConfigCore.so.*.*
93 %attr(755,root,root) %ghost %{_libdir}/libKF5ConfigGui.so.5
94 %attr(755,root,root) %{_libdir}/libKF5ConfigGui.so.*.*
95 %attr(755,root,root) %{_bindir}/kreadconfig5
96 %attr(755,root,root) %{_bindir}/kwriteconfig5
97 %attr(755,root,root) %{_libdir}/kf5/kconf_update
98 %attr(755,root,root) %{_libdir}/kf5/kconfig_compiler_kf5
99 %dir %{_datadir}/kconf_update
100
101 %files devel
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_libdir}/libKF5ConfigCore.so
104 %attr(755,root,root) %{_libdir}/libKF5ConfigGui.so
105 %{_includedir}/KF5/KConfigCore
106 %{_includedir}/KF5/KConfigGui
107 %{_includedir}/KF5/kconfig_version.h
108 %{_libdir}/cmake/KF5Config
109 %{qt5dir}/mkspecs/modules/qt_KConfigCore.pri
110 %{qt5dir}/mkspecs/modules/qt_KConfigGui.pri
This page took 0.059733 seconds and 3 git commands to generate.