]> git.pld-linux.org Git - packages/kf5-kconfig.git/blob - kf5-kconfig.spec
- up to 5.4.0
[packages/kf5-kconfig.git] / kf5-kconfig.spec
1 # TODO:
2 # - dir /usr/include/KF5 not packaged
3 %define         kdeframever     5.4
4 %define         qtver           5.3.2
5 %define         kfname          kconfig
6
7 Summary:        Backend for storing application configuration
8 Name:           kf5-%{kfname}
9 Version:        5.4.0
10 Release:        0.1
11 License:        LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  2fcd2787e5c3c2df7265fc9f6ec8af10
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Gui-devel >= %{qtver}
18 BuildRequires:  Qt5Test-devel >= %{qtver}
19 BuildRequires:  Qt5Xml-devel >= %{qtver}
20 BuildRequires:  cmake >= 2.8.12
21 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
22 BuildRequires:  qt5-linguist >= %{qtver}
23 BuildRequires:  rpmbuild(macros) >= 1.164
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  xz
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         qt5dir          %{_libdir}/qt5
29
30 %description
31 KConfig provides an advanced configuration system. It is made of two
32 parts: KConfigCore and KConfigGui.
33
34 KConfigCore provides access to the configuration files themselves. It
35 features:
36
37 - Code generation: describe your configuration in an XML file, and use
38   `kconfig_compiler to generate classes that read and write
39   configuration entries.
40 - Cascading configuration files (global settings overridden by local
41   settings).
42 - Optional shell expansion support (see [docs/options.md](@ref
43   options)).
44 - The ability to lock down configuration options (see
45   [docs/options.md](@ref options)).
46
47 KConfigGui provides a way to hook widgets to the configuration so that
48 they are automatically initialized from the configuration and
49 automatically propagate their changes to their respective
50 configuration files.
51
52 %package devel
53 Summary:        Header files for %{kfname} development
54 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
55 Group:          X11/Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57
58 %description devel
59 Header files for %{kfname} development.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe dla programistów używających %{kfname}.
63
64 %prep
65 %setup -q -n %{kfname}-%{version}
66
67 %build
68 install -d build
69 cd build
70 %cmake \
71         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
72         ../
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} -C build/ install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %find_lang %{kfname}5_qt --with-qm
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files -f %{kfname}5_qt.lang
90 %defattr(644,root,root,755)
91 %doc DESIGN README.md TODO
92 %attr(755,root,root) %ghost %{_libdir}/libKF5ConfigCore.so.5
93 %attr(755,root,root) %{_libdir}/libKF5ConfigCore.so.5.4.0
94 %attr(755,root,root) %ghost %{_libdir}/libKF5ConfigGui.so.5
95 %attr(755,root,root) %{_libdir}/libKF5ConfigGui.so.5.4.0
96 %attr(755,root,root) %{_bindir}/kconfig_compiler_kf5
97 %attr(755,root,root) %{_bindir}/kreadconfig5
98 %attr(755,root,root) %{_bindir}/kwriteconfig5
99 %attr(755,root,root) %{_libdir}/kf5/kconf_update
100
101 %files devel
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_libdir}/libKF5ConfigCore.so
104 %attr(755,root,root) %{_libdir}/libKF5ConfigGui.so
105 %{_includedir}/KF5/KConfigCore
106 %{_includedir}/KF5/KConfigGui
107 %{_includedir}/KF5/kconfig_version.h
108 %{_libdir}/cmake/KF5Config
109 %{qt5dir}/mkspecs/modules/qt_KConfigCore.pri
110 %{qt5dir}/mkspecs/modules/qt_KConfigGui.pri
This page took 0.074057 seconds and 3 git commands to generate.