]> git.pld-linux.org Git - packages/kf5-kcompletion.git/blob - kf5-kcompletion.spec
e80efd2c8afb1b5e3e95f0e8e1d647fc68b3f75a
[packages/kf5-kcompletion.git] / kf5-kcompletion.spec
1 # TODO:
2 # - runtime Requires if any
3 %define         kdeframever     5.53
4 %define         qtver           5.9.0
5 %define         kfname          kcompletion
6
7 Summary:        String completion framework
8 Name:           kf5-%{kfname}
9 Version:        5.53.0
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  113a86c053589b02024fe2e2052968b1
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5DBus-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel >= %{qtver}
19 BuildRequires:  Qt5Test-devel >= %{qtver}
20 BuildRequires:  Qt5Widgets-devel >= %{qtver}
21 BuildRequires:  Qt5Xml-devel >= %{qtver}
22 BuildRequires:  cmake >= 2.8.12
23 BuildRequires:  kf5-kconfig-devel >= %{version}
24 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
25 BuildRequires:  kf5-kwidgetsaddons-devel >= %{version}
26 BuildRequires:  polkit-qt-1-devel
27 BuildRequires:  qt5-linguist >= %{qtver}
28 BuildRequires:  rpmbuild(macros) >= 1.164
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 Requires:       kf5-dirs
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         qt5dir          %{_libdir}/qt5
35
36 %description
37 This class offers "auto-completion", "manual-completion" or "shell
38 completion" on QString objects. A common use is completing filenames
39 or URLs. It can also be used for completing email-addresses,
40 telephone-numbers, commands, SQL queries, etc.
41
42 %package devel
43 Summary:        Header files for %{kfname} development
44 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
45 Group:          X11/Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       Qt5Widgets-devel >= %{qtver}
48 Requires:       cmake >= 2.6.0
49
50 %description devel
51 Header files for %{kfname} development.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe dla programistów używających %{kfname}.
55
56 %prep
57 %setup -q -n %{kfname}-%{version}
58
59 %build
60 install -d build
61 cd build
62 %cmake \
63         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
64         ../
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} -C build/ install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %files -f %{kfname}5_qt.lang
82 %defattr(644,root,root,755)
83 %doc README.md
84 %attr(755,root,root) %ghost %{_libdir}/libKF5Completion.so.5
85 %attr(755,root,root) %{_libdir}/libKF5Completion.so.*.*
86
87 %files devel
88 %defattr(644,root,root,755)
89 %{_includedir}/KF5/KCompletion
90 %{_includedir}/KF5/kcompletion_version.h
91 %{_libdir}/cmake/KF5Completion
92 %{_libdir}/libKF5Completion.so
93 %{qt5dir}/mkspecs/modules/qt_KCompletion.pri
This page took 0.06667 seconds and 2 git commands to generate.