]> git.pld-linux.org Git - packages/kf5-kcompletion.git/blob - kf5-kcompletion.spec
87dd73ad91742e55533002e303410418ae7faeb9
[packages/kf5-kcompletion.git] / kf5-kcompletion.spec
1 # TODO:
2 # - proper place for *.pri,
3 # - set ECM_MKSPECS_INSTALL_DIR in kde5-extra-cmake-modules
4 # - _IMPORT_PREFIX also must be set somewhere
5 # - runtime Requires if any
6 # - these dirs are not own by any package
7 #  /usr/include/KF5
8 #  /usr/lib/libexec
9 #  /usr/lib/plugins
10 #  /usr/share/kf5
11 %define         _state          stable
12 %define         orgname         kcompletion
13
14 Summary:        String completion framework
15 Name:           kf5-%{orgname}
16 Version:        5.0.0
17 Release:        0.1
18 License:        GPL v2+/LGPL v2.1+
19 Group:          X11/Libraries
20 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
21 # Source0-md5:  a37e78ff2c09fb4287dc92f40837f6b3
22 URL:            http://www.kde.org/
23 BuildRequires:  Qt5Core-devel >= 5.2.0
24 BuildRequires:  Qt5DBus-devel
25 BuildRequires:  Qt5Gui-devel >= 5.3.1
26 BuildRequires:  Qt5Test-devel
27 BuildRequires:  Qt5Widgets-devel
28 BuildRequires:  Qt5Xml-devel
29 BuildRequires:  cmake >= 2.8.12
30 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
31 BuildRequires:  kf5-kwidgetsaddons-devel >= %{version}
32 BuildRequires:  polkit-qt-1-devel
33 BuildRequires:  qt5-linguist
34 BuildRequires:  rpmbuild(macros) >= 1.164
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xz
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         qt5dir          %{_libdir}/qt5
40
41 %description
42 This class offers "auto-completion", "manual-completion" or "shell
43 completion" on QString objects. A common use is completing filenames
44 or URLs. It can also be used for completing email-addresses,
45 telephone-numbers, commands, SQL queries, etc.
46
47 %package devel
48 Summary:        Header files for %{orgname} development
49 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{orgname}
50 Group:          X11/Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52
53 %description devel
54 Header files for %{orgname} development.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe dla programistów używających %{orgname}.
58
59 %prep
60 %setup -q -n %{orgname}-%{version}
61
62 %build
63 install -d build
64 cd build
65 %cmake \
66         -DBIN_INSTALL_DIR=%{_bindir} \
67         -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
68         -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
69         -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
70         -DQML_INSTALL_DIR=%{qt5dir}/qml \
71         -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
72         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
73         -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
74         -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
75         -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
76         -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
77         -D_IMPORT_PREFIX=%{_prefix} \
78         ../
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} -C build/ install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %find_lang %{orgname}5_qt --with-qm
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files -f %{orgname}5_qt.lang
96 %defattr(644,root,root,755)
97 %doc README.md
98 %attr(755,root,root) %ghost %{_libdir}/libKF5Completion.so.5
99 %attr(755,root,root) %{_libdir}/libKF5Completion.so.5.0.0
100
101 %files devel
102 %defattr(644,root,root,755)
103 %{_includedir}/KF5/KCompletion
104 %{_includedir}/KF5/kcompletion_version.h
105 %{_libdir}/cmake/KF5Completion
106 %{_libdir}/libKF5Completion.so
107 %{qt5dir}/mkspecs/modules/qt_KCompletion.pri
This page took 0.064651 seconds and 2 git commands to generate.