]> git.pld-linux.org Git - packages/kf5-kcompletion.git/blob - kf5-kcompletion.spec
- up to 5.4.0
[packages/kf5-kcompletion.git] / kf5-kcompletion.spec
1 # TODO:
2 # - runtime Requires if any
3 # - these dirs are not own by any package
4 #  /usr/include/KF5
5 #  /usr/share/kf5
6 %define         kdeframever     5.4
7 %define         qtver           5.3.2
8 %define         kfname          kcompletion
9
10 Summary:        String completion framework
11 Name:           kf5-%{kfname}
12 Version:        5.4.0
13 Release:        0.1
14 License:        GPL v2+/LGPL v2.1+
15 Group:          X11/Libraries
16 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
17 # Source0-md5:  816227f5a9e2f06792cce31d544e877f
18 URL:            http://www.kde.org/
19 BuildRequires:  Qt5Core-devel >= %{qtver}
20 BuildRequires:  Qt5DBus-devel >= %{qtver}
21 BuildRequires:  Qt5Gui-devel >= %{qtver}
22 BuildRequires:  Qt5Test-devel >= %{qtver}
23 BuildRequires:  Qt5Widgets-devel >= %{qtver}
24 BuildRequires:  Qt5Xml-devel >= %{qtver}
25 BuildRequires:  cmake >= 2.8.12
26 BuildRequires:  kf5-kconfig-devel >= %{version}
27 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
28 BuildRequires:  kf5-kwidgetsaddons-devel >= %{version}
29 BuildRequires:  polkit-qt-1-devel
30 BuildRequires:  qt5-linguist >= %{qtver}
31 BuildRequires:  rpmbuild(macros) >= 1.164
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         qt5dir          %{_libdir}/qt5
37
38 %description
39 This class offers "auto-completion", "manual-completion" or "shell
40 completion" on QString objects. A common use is completing filenames
41 or URLs. It can also be used for completing email-addresses,
42 telephone-numbers, commands, SQL queries, etc.
43
44 %package devel
45 Summary:        Header files for %{kfname} development
46 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
47 Group:          X11/Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49
50 %description devel
51 Header files for %{kfname} development.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe dla programistów używających %{kfname}.
55
56 %prep
57 %setup -q -n %{kfname}-%{version}
58
59 %build
60 install -d build
61 cd build
62 %cmake \
63         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
64         ../
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} -C build/ install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %find_lang %{kfname}5_qt --with-qm
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %files -f %{kfname}5_qt.lang
82 %defattr(644,root,root,755)
83 %doc README.md
84 %attr(755,root,root) %ghost %{_libdir}/libKF5Completion.so.5
85 %attr(755,root,root) %{_libdir}/libKF5Completion.so.5.4.0
86
87 %files devel
88 %defattr(644,root,root,755)
89 %{_includedir}/KF5/KCompletion
90 %{_includedir}/KF5/kcompletion_version.h
91 %{_libdir}/cmake/KF5Completion
92 %{_libdir}/libKF5Completion.so
93 %{qt5dir}/mkspecs/modules/qt_KCompletion.pri
This page took 0.071961 seconds and 3 git commands to generate.