]> git.pld-linux.org Git - packages/kf5-kcodecs.git/blob - kf5-kcodecs.spec
- updated to 5.56
[packages/kf5-kcodecs.git] / kf5-kcodecs.spec
1 # TODO:
2 # - runtime Requires if any
3 %define         kdeframever     5.56
4 %define         qtver           5.9.0
5 %define         kfname          kcodecs
6
7 Summary:        String encoding
8 Name:           kf5-%{kfname}
9 Version:        5.56.0
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  a3cda4ef6700a9975225f2fc6544ceb6
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Test-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  kf5-extra-cmake-modules >= %{version}
20 BuildRequires:  ninja
21 BuildRequires:  qt5-linguist >= %{qtver}
22 BuildRequires:  rpmbuild(macros) >= 1.164
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 Requires:       kf5-dirs
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 KCodecs provide a collection of methods to manipulate strings using
30 various encodings. It supports:
31
32 - base64
33 - uu
34 - quoted-printable
35
36 %package devel
37 Summary:        Header files for %{kfname} development
38 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
39 Group:          X11/Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       Qt5Core-devel >= %{qtver}
42 Requires:       cmake >= 2.6.0
43
44 %description devel
45 Header files for %{kfname} development.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe dla programistów używających %{kfname}.
49
50 %prep
51 %setup -q -n %{kfname}-%{version}
52
53 %build
54 install -d build
55 cd build
56 %cmake -G Ninja \
57         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
58         ../
59 %ninja_build
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 %ninja_install -C build
64
65 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post -p /sbin/ldconfig
71 %postun -p /sbin/ldconfig
72
73 %files -f %{kfname}5_qt.lang
74 %defattr(644,root,root,755)
75 %doc README.md
76 %attr(755,root,root) %ghost %{_libdir}/libKF5Codecs.so.5
77 %attr(755,root,root) %{_libdir}/libKF5Codecs.so.*.*
78 /etc/xdg/kcodecs.categories
79
80 %files devel
81 %defattr(644,root,root,755)
82 %attr(755,root,root) %{_libdir}/libKF5Codecs.so
83 %{_includedir}/KF5/KCodecs
84 %{_includedir}/KF5/kcodecs_version.h
85 %{_libdir}/cmake/KF5Codecs
86 %{_libdir}/qt5/mkspecs/modules/qt_KCodecs.pri
This page took 0.066923 seconds and 4 git commands to generate.