]> git.pld-linux.org Git - packages/kf5-kcodecs.git/blob - kf5-kcodecs.spec
2235f34e37e8cedec135de7b129aa44672c504f6
[packages/kf5-kcodecs.git] / kf5-kcodecs.spec
1 # TODO:
2 # - runtime Requires if any
3 %define         kdeframever     5.19
4 %define         qtver           5.3.2
5 %define         kfname          kcodecs
6
7 Summary:        String encoding
8 Name:           kf5-%{kfname}
9 Version:        5.19.0
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  7569f06a767ddd08ece025fe50197eba
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Test-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  kf5-extra-cmake-modules >= %{version}
20 BuildRequires:  qt5-linguist >= %{qtver}
21 BuildRequires:  rpmbuild(macros) >= 1.164
22 BuildRequires:  tar >= 1:1.22
23 BuildRequires:  xz
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 KCodecs provide a collection of methods to manipulate strings using
28 various encodings. It supports:
29
30 - base64
31 - uu
32 - quoted-printable
33
34 %package devel
35 Summary:        Header files for %{kfname} development
36 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
37 Group:          X11/Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description devel
41 Header files for %{kfname} development.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe dla programistów używających %{kfname}.
45
46 %prep
47 %setup -q -n %{kfname}-%{version}
48
49 %build
50 install -d build
51 cd build
52 %cmake \
53         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
54         ../
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} -C build/ install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %post -p /sbin/ldconfig
69 %postun -p /sbin/ldconfig
70
71 %files -f %{kfname}5_qt.lang
72 %defattr(644,root,root,755)
73 %doc README.md
74 %attr(755,root,root) %ghost %{_libdir}/libKF5Codecs.so.5
75 %attr(755,root,root) %{_libdir}/libKF5Codecs.so.*.*
76
77 %files devel
78 %defattr(644,root,root,755)
79 %attr(755,root,root) %{_libdir}/libKF5Codecs.so
80 %{_includedir}/KF5/KCodecs
81 %{_includedir}/KF5/kcodecs_version.h
82 %{_libdir}/cmake/KF5Codecs
83 %{_libdir}/qt5/mkspecs/modules/qt_KCodecs.pri
This page took 0.025997 seconds and 3 git commands to generate.