]> git.pld-linux.org Git - packages/kf5-kcalendarcore.git/blob - kf5-kcalendarcore.spec
8f0f7f17b9059d7d5f4bc18fae1c5097900f1bee
[packages/kf5-kcalendarcore.git] / kf5-kcalendarcore.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeframever     5.113
5 %define         qtver           5.15.2
6 %define         kfname          kcalendarcore
7 Summary:        kcalendarcore
8 Name:           kf5-%{kfname}
9 Version:        5.113.0
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  a0e98fee032e1b462a4b0a302b10f15b
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Gui-devel
18 BuildRequires:  Qt5Test-devel >= 5.9.0
19 BuildRequires:  cmake >= 3.16.0
20 BuildRequires:  kf5-extra-cmake-modules >= 5.53.0
21 BuildRequires:  libical-devel >= 2.0
22 BuildRequires:  ninja
23 BuildRequires:  qt5-build >= %{qtver}
24 BuildRequires:  rpmbuild(macros) >= 1.164
25 BuildRequires:  shared-mime-info
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 Obsoletes:      ka5-kcalcore < 20.12.3
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This library provides access to and handling of calendar data. It
33 supports the standard formats iCalendar and vCalendar and the group
34 scheduling standard iTIP.
35
36 A calendar contains information like incidences (events, to-dos,
37 journals), alarms, time zones, and other useful information. This API
38 provides access to that calendar information via well known calendar
39 formats iCalendar (or iCal) and the oolder vCalendar.
40
41 %package devel
42 Summary:        Header files for %{kfname} development
43 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
44 Group:          X11/Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Obsoletes:      ka5-kcalcore-devel < 20.12.3
47
48 %description devel
49 Header files for %{kfname} development.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe dla programistów używających %{kfname}.
53
54 %prep
55 %setup -q -n %{kfname}-%{version}
56
57 %build
58 %cmake -B build \
59         -G Ninja \
60         %{!?with_tests:-DBUILD_TESTING=OFF} \
61         -DHTML_INSTALL_DIR=%{_kdedocdir} \
62         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
63
64 %ninja_build -C build
65
66 %if %{with tests}
67 %ninja_build -C build test
68 %endif
69
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 %ninja_install -C build
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post   -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %files
82 %defattr(644,root,root,755)
83 %ghost %{_libdir}/libKF5CalendarCore.so.5
84 %attr(755,root,root) %{_libdir}/libKF5CalendarCore.so.5.*.*
85 %{_datadir}/qlogging-categories5/kcalendarcore.categories
86 %{_datadir}/qlogging-categories5/kcalendarcore.renamecategories
87
88 %files devel
89 %defattr(644,root,root,755)
90 %{_libdir}/cmake/KF5CalendarCore
91 %{_libdir}/libKF5CalendarCore.so
92 %{_libdir}/qt5/mkspecs/modules/qt_KCalendarCore.pri
93 %{_includedir}/KF5/kcalcore_version.h
94 %{_includedir}/KF5/KCalendarCore
95 %{_pkgconfigdir}/KF5CalendarCore.pc
This page took 0.096236 seconds and 2 git commands to generate.