]> git.pld-linux.org Git - packages/kf5-extra-cmake-modules.git/blob - kf5-extra-cmake-modules.spec
-updated to 5.24.0; fetch sources
[packages/kf5-extra-cmake-modules.git] / kf5-extra-cmake-modules.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         orgname         extra-cmake-modules
6 %define         kdeframever     5.24
7 Summary:        Extra Cmake Modules for KF5
8 Name:           kf5-%{orgname}
9 Version:        5.24.0
10 Release:        1
11 License:        BSD
12 Group:          Development/Building
13 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{orgname}-%{version}.tar.xz
14 # Source0-md5:  cd3b0c844234ad29cfdba89d63ccb2ae
15 URL:            http://www.kde.org/
16 BuildRequires:  cmake >= 2.8.12
17 BuildRequires:  qt5-linguist
18 BuildRequires:  rpmbuild(macros) >= 1.698
19 BuildRequires:  sphinx-pdg
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 Requires:       kf5-dirs
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         qt5dir          %{_libdir}/qt5
26
27 %description
28 The Extra CMake Modules package, or ECM, adds to the modules provided
29 by CMake, including both ones used by find_package() to find common
30 software and ones that can be used directly in CMakeLists.txt files to
31 perform common tasks.
32
33 In addition, it provides common build settings used in software
34 produced by the KDE community.
35
36 While the driving force of this module is to reduce duplication in
37 CMake scripts across KDE software, it is intended to be useful for any
38 software that uses the CMake build system.
39
40 %prep
41 %setup -q -n %{orgname}-%{version}
42
43 %build
44 install -d build
45 cd build
46 %cmake \
47         ../
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 %{__make} -C build/ install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 mv $RPM_BUILD_ROOT%{_docdir}/ECM ECM-doc
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc COPYING-CMAKE-SCRIPTS README.rst ECM-doc/*
65 %{_datadir}/ECM
66 %{_mandir}/man7/ecm*.7*
This page took 0.066129 seconds and 4 git commands to generate.