]> git.pld-linux.org Git - packages/kf5-extra-cmake-modules.git/blob - kf5-extra-cmake-modules.spec
- up to 1.4.0; drop tons of unneeded defines; run tests
[packages/kf5-extra-cmake-modules.git] / kf5-extra-cmake-modules.spec
1 %bcond_without  tests
2
3 %define         _state          stable
4 %define         orgname         extra-cmake-modules
5 %define         kdeframever     5.4
6
7 Summary:        Extra Cmake Modules for KF5
8 Name:           kf5-extra-cmake-modules
9 Version:        1.4.0
10 Release:        1
11 License:        BSD
12 Group:          Development/Building
13 Source0:        http://download.kde.org/%{_state}/frameworks/%{kdeframever}/%{orgname}-%{version}.tar.xz
14 # Source0-md5:  a8a8278f5448a584cffec07692ed9f19
15 URL:            http://www.kde.org/
16 BuildRequires:  cmake >= 2.8.12
17 BuildRequires:  qt5-linguist
18 BuildRequires:  rpmbuild(macros) >= 1.164
19 BuildRequires:  sphinx-pdg
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         qt5dir          %{_libdir}/qt5
25
26 %description
27 The Extra CMake Modules package, or ECM, adds to the modules provided
28 by CMake, including both ones used by ``find_package()`` to find
29 common software and ones that can be used directly in
30 ``CMakeLists.txt`` files to perform common tasks.
31
32 In addition, it provides common build settings used in software
33 produced by the KDE community.
34
35 While the driving force of this module is to reduce duplication in
36 CMake scripts across KDE software, it is intended to be useful for any
37 software that uses the CMake build system.
38
39 %prep
40 %setup -q -n %{orgname}-%{version}
41
42 %build
43 install -d build
44 cd build
45 %cmake \
46         ../
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} -C build/ install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 mv $RPM_BUILD_ROOT%{_docdir}/ECM ECM-doc
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc COPYING-CMAKE-SCRIPTS README.rst ECM-doc/*
65 %{_datadir}/ECM
66 %{_mandir}/man7/ecm*.7*
This page took 0.03317 seconds and 4 git commands to generate.