]> git.pld-linux.org Git - packages/kf5-extra-cmake-modules.git/blob - kf5-extra-cmake-modules.spec
ddc2978021105e7cb97bd7b0325130a22d8c80af
[packages/kf5-extra-cmake-modules.git] / kf5-extra-cmake-modules.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define         orgname         extra-cmake-modules
6 %define         kdeframever     5.39
7 Summary:        Extra Cmake Modules for KF5
8 Name:           kf5-%{orgname}
9 Version:        5.39.0
10 Release:        1
11 License:        BSD
12 Group:          Development/Building
13 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{orgname}-%{version}.tar.xz
14 # Source0-md5:  777b57222f5c23d1599b8e8774e96b73
15 URL:            http://www.kde.org/
16 BuildRequires:  cmake >= 2.8.12
17 BuildRequires:  qt5-assistant
18 BuildRequires:  qt5-linguist
19 BuildRequires:  rpmbuild(macros) >= 1.698
20 BuildRequires:  sphinx-pdg
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 Requires:       kf5-dirs
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         qt5dir          %{_libdir}/qt5
27
28 %description
29 The Extra CMake Modules package, or ECM, adds to the modules provided
30 by CMake, including both ones used by find_package() to find common
31 software and ones that can be used directly in CMakeLists.txt files to
32 perform common tasks.
33
34 In addition, it provides common build settings used in software
35 produced by the KDE community.
36
37 While the driving force of this module is to reduce duplication in
38 CMake scripts across KDE software, it is intended to be useful for any
39 software that uses the CMake build system.
40
41 %prep
42 %setup -q -n %{orgname}-%{version}
43
44 %build
45 install -d build
46 cd build
47 %cmake \
48         ../
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 %{__make} -C build install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 mv $RPM_BUILD_ROOT%{_docdir}/ECM ECM-doc
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc COPYING-CMAKE-SCRIPTS README.rst ECM-doc/*
66 %{_datadir}/ECM
67 %{_mandir}/man7/ecm*.7*
This page took 0.032252 seconds and 3 git commands to generate.