]> git.pld-linux.org Git - packages/kf5-extra-cmake-modules.git/blob - kf5-extra-cmake-modules.spec
- up to 5.10.0
[packages/kf5-extra-cmake-modules.git] / kf5-extra-cmake-modules.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         orgname         extra-cmake-modules
6 %define         kdeframever     5.10
7 Summary:        Extra Cmake Modules for KF5
8 Name:           kf5-%{orgname}
9 Version:        5.10.0
10 Release:        1
11 License:        BSD
12 Group:          Development/Building
13 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{orgname}-%{version}.tar.xz
14 # Source0-md5:  a97dad81fb7327c8ff78406ed369d484
15 URL:            http://www.kde.org/
16 BuildRequires:  cmake >= 2.8.12
17 BuildRequires:  qt5-linguist
18 BuildRequires:  rpmbuild(macros) >= 1.698
19 BuildRequires:  sphinx-pdg
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         qt5dir          %{_libdir}/qt5
25
26 %description
27 The Extra CMake Modules package, or ECM, adds to the modules provided
28 by CMake, including both ones used by find_package() to find common
29 software and ones that can be used directly in CMakeLists.txt files to
30 perform common tasks.
31
32 In addition, it provides common build settings used in software
33 produced by the KDE community.
34
35 While the driving force of this module is to reduce duplication in
36 CMake scripts across KDE software, it is intended to be useful for any
37 software that uses the CMake build system.
38
39 %prep
40 %setup -q -n %{orgname}-%{version}
41
42 %build
43 install -d build
44 cd build
45 %cmake \
46         ../
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 %{__make} -C build/ install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 mv $RPM_BUILD_ROOT%{_docdir}/ECM ECM-doc
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc COPYING-CMAKE-SCRIPTS README.rst ECM-doc/*
64 %{_datadir}/ECM
65 %{_mandir}/man7/ecm*.7*
This page took 0.036311 seconds and 3 git commands to generate.