]> git.pld-linux.org Git - packages/kf5-breeze-icons.git/blob - kf5-breeze-icons.spec
- updated to 5.103.0
[packages/kf5-breeze-icons.git] / kf5-breeze-icons.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeframever     5.103
5 %define         qtver           5.15.2
6 %define         kfname          breeze-icons
7
8 Summary:        breeze icons
9 Name:           kf5-%{kfname}
10 Version:        5.103.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  60d0eadf3f9c87ee652e024d9623c551
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Test-devel >= %{qtver}
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  gettext-devel
21 BuildRequires:  kf5-extra-cmake-modules >= %{version}
22 BuildRequires:  ninja
23 BuildRequires:  pkgconfig
24 BuildRequires:  qt5-linguist >= %{qtver}
25 BuildRequires:  rpmbuild(macros) >= 1.164
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 Requires:       kf5-dirs
29 Obsoletes:      breeze-icon-theme
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         qt5dir          %{_libdir}/qt5
34
35 %description
36 Breeze-icons is a freedesktop.org compatible icon theme.
37
38 %prep
39 %setup -q -n %{kfname}-%{version}
40
41 %build
42 install -d build
43 cd build
44 %cmake -G Ninja \
45         %{!?with_tests:-DBUILD_TESTING=OFF} \
46         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
47         ../
48 %ninja_build
49
50 %if %{with tests}
51 ctest
52 %endif
53
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 %ninja_install -C build
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %{_iconsdir}/breeze
65 %{_iconsdir}/breeze-dark
This page took 0.104504 seconds and 3 git commands to generate.