]> git.pld-linux.org Git - packages/kf5-attica.git/blob - kf5-attica.spec
relup
[packages/kf5-attica.git] / kf5-attica.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 # TODO:
6 # - runtime Requires if any
7
8 %define         kdeframever     5.97
9 %define         qtver           5.15.2
10 %define         kfname          attica
11 Summary:        A Qt library that implements the Open Collaboration Services API
12 Name:           kf5-%{kfname}
13 Version:        5.97.0
14 Release:        2
15 License:        GPL v2+/LGPL v2.1+
16 Group:          X11/Libraries
17 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
18 # Source0-md5:  b6bc2ad39f48daf021eb6e3146ea1b2f
19 URL:            http://www.kde.org/
20 BuildRequires:  Qt5Core-devel >= %{qtver}
21 BuildRequires:  Qt5Network-devel >= %{qtver}
22 %if %{with tests}
23 BuildRequires:  Qt5Test-devel >= %{qtver}
24 %endif
25 BuildRequires:  cmake >= 3.16
26 BuildRequires:  kf5-extra-cmake-modules >= %{version}
27 BuildRequires:  ninja
28 BuildRequires:  qt5-build >= %{qtver}
29 BuildRequires:  rpmbuild(macros) >= 1.736
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xz
32 Requires:       Qt5Core >= %{qtver}
33 Requires:       Qt5Network >= %{qtver}
34 Requires:       kf5-dirs
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Attica is a Qt library that implements the Open Collaboration Services
39 API version 1.6. The REST API is defined here:
40 <http://freedesktop.org/wiki/Specifications/open-collaboration-services-draft/>.
41
42 It grants easy access to the services such as querying information
43 about persons and contents. The library is used in KNewStuff3 as
44 content provider. In order to integrate with KDE's Plasma Desktop, a
45 platform plugin exists in kdebase.
46
47 %package devel
48 Summary:        Header files for %{kfname} development
49 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
50 Group:          X11/Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       Qt5Core-devel >= %{qtver}
53 Requires:       Qt5Network-devel >= %{qtver}
54
55 %description devel
56 Header files for %{kfname} development.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe dla programistów używających %{kfname}.
60
61 %prep
62 %setup -q -n %{kfname}-%{version}
63
64 %build
65 install -d build
66 cd build
67 %cmake -G Ninja \
68         %{!?with_tests:-DBUILD_TESTING=OFF} \
69         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
70         ..
71 %ninja_build
72
73 %{?with_tests:%ninja_build test}
74
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 %ninja_install -C build
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post   -p /sbin/ldconfig
84 %postun -p /sbin/ldconfig
85
86 %files
87 %defattr(644,root,root,755)
88 %doc AUTHORS README.md
89 %attr(755,root,root) %{_libdir}/libKF5Attica.so.*.*.*
90 %ghost %{_libdir}/libKF5Attica.so.5
91 %{_datadir}/qlogging-categories5/attica.categories
92 %{_datadir}/qlogging-categories5/attica.renamecategories
93
94 %files devel
95 %defattr(644,root,root,755)
96 %{_libdir}/libKF5Attica.so
97 %{_includedir}/KF5/Attica
98 %{_libdir}/cmake/KF5Attica
99 %{_pkgconfigdir}/libKF5Attica.pc
100 %{_libdir}/qt5/mkspecs/modules/qt_Attica.pri
This page took 0.052709 seconds and 3 git commands to generate.