]> git.pld-linux.org Git - packages/kealib.git/blob - kealib.spec
a02a9589887a55e8c1e52c54aceb21f2e19d372e
[packages/kealib.git] / kealib.spec
1 #
2 # Conditional build:
3 %bcond_with     gdal    # GDAL module [since 2.0 GDAL has builtin KEA support]
4 #
5 Summary:        KEALib - HDF5 based raster file format library
6 Summary(pl.UTF-8):      KEALib - biblioteka rastrowego formatu plików opartego na HDF5
7 Name:           kealib
8 Version:        1.4.14
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 Source0:        https://github.com/ubarsc/kealib/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  494e9efc0c26f904c02c31fe2e668885
14 Patch0:         %{name}-config.patch
15 URL:            http://kealib.org/
16 BuildRequires:  cmake >= 2.6.0
17 %{?with_gdal:BuildRequires:     gdal-devel}
18 BuildRequires:  hdf5-c++-devel
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  rpmbuild(macros) >= 1.605
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 LibKEA is a project to provide an implementation of the GDAL
25 specification within the the HDF5 file format. Specifically, the
26 format will support raster attribute tables (commonly not included
27 within other formats), image pyramids, GDAL meta-data, in-built
28 statistics while also providing large file handling with compression
29 used throughout the file. Being based on the HDF5 standard, it will
30 also provide a base from which other formats could be derived and will
31 be a good choice for long term data archiving. An independent software
32 library (libKEA) has been provided through which complete access to
33 the KEA image format is provided alongside a GDAL driver allowing KEA
34 images to be used through any GDAL supported software.
35
36 %description -l pl.UTF-8
37 LibKEA to projekt dostarczający implementację specyfikacji GDAL
38 wewnątrz formatu plików HDF5. W szczególności format obsługuje tablice
39 atrybutów rastrowych (zwykle nie zawartych w innych formatach),
40 piramidy obrazów, metadane GDAL i statystyki wbudowane, zapewniając
41 także obsługę dużych plików z kompresją. Dzięki oparciu na standardzie
42 HDF5, zapewnia także podstawę, z której mogą wywodzić się inne
43 formaty; jest także dobrym wyborem do długoterminowej archiwizacji
44 danych. Udostępniono niezależną bibliotekę (libKEA), dającą pełny
45 dostęp do formatu obrazów KEA, a także sterownik GDA pozwalający na
46 używanie obrazów KEA w programach obsługujących GDAL.
47
48 %package devel
49 Summary:        Header files for LibKEA library
50 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LibKEA
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       hdf5-c++-devel
54 Requires:       libstdc++-devel
55
56 %description devel
57 Header files for LibKEA library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki LibKEA.
61
62 %package -n gdal-kea
63 Summary:        KEA plugin for GDAL library
64 Summary(pl.UTF-8):      Wtyczka KEA do biblioteki GDAL
65 Group:          Libraries
66 Requires:       %{name} = %{version}-%{release}
67 %if %{with gdal}
68 %requires_ge    gdal
69 %endif
70
71 %description -n gdal-kea
72 KEA plugin for GDAL library.
73
74 %description -n gdal-kea -l pl.UTF-8
75 Wtyczka KEA do biblioteki GDAL.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80
81 %build
82 %cmake . \
83 %if %{with gdal}
84         -DGDAL_INCLUDE_DIR=%{_includedir}/gdal \
85         -DGDAL_LIB_PATH=%{_libdir} \
86 %endif
87         -DHDF5_INCLUDE_DIR=%{_includedir} \
88         -DHDF5_LIB_PATH=%{_libdir}
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %doc README.md
106 %attr(755,root,root) %{_libdir}/libkea.so.*.*.*
107 %attr(755,root,root) %ghost %{_libdir}/libkea.so.1.4
108
109 %files devel
110 %defattr(644,root,root,755)
111 %attr(755,root,root) %{_bindir}/kea-config
112 %attr(755,root,root) %{_libdir}/libkea.so
113 %{_includedir}/libkea
114
115 %if %{with gdal}
116 %files -n gdal-kea
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_libdir}/gdalplugins/gdal_KEA.so
119 %endif
This page took 0.061798 seconds and 2 git commands to generate.