]> git.pld-linux.org Git - packages/kealib.git/blob - kealib.spec
hack broken kealib-config; rel 2
[packages/kealib.git] / kealib.spec
1 #
2 # Conditional build:
3 %bcond_with     gdal    # GDAL module [since 2.0 GDAL has builtin KEA support]
4 #
5 Summary:        KEALib - HDF5 based raster file format library
6 Summary(pl.UTF-8):      KEALib - biblioteka rastrowego formatu plików opartego na HDF5
7 Name:           kealib
8 Version:        1.4.14
9 Release:        2
10 License:        MIT
11 Group:          Libraries
12 Source0:        https://github.com/ubarsc/kealib/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  494e9efc0c26f904c02c31fe2e668885
14 Patch0:         %{name}-config.patch
15 Patch1:         %{name}-hdf5_libs.patch
16 URL:            http://kealib.org/
17 BuildRequires:  cmake >= 2.6.0
18 %{?with_gdal:BuildRequires:     gdal-devel}
19 BuildRequires:  hdf5-c++-devel
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  rpmbuild(macros) >= 1.605
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 LibKEA is a project to provide an implementation of the GDAL
26 specification within the the HDF5 file format. Specifically, the
27 format will support raster attribute tables (commonly not included
28 within other formats), image pyramids, GDAL meta-data, in-built
29 statistics while also providing large file handling with compression
30 used throughout the file. Being based on the HDF5 standard, it will
31 also provide a base from which other formats could be derived and will
32 be a good choice for long term data archiving. An independent software
33 library (libKEA) has been provided through which complete access to
34 the KEA image format is provided alongside a GDAL driver allowing KEA
35 images to be used through any GDAL supported software.
36
37 %description -l pl.UTF-8
38 LibKEA to projekt dostarczający implementację specyfikacji GDAL
39 wewnątrz formatu plików HDF5. W szczególności format obsługuje tablice
40 atrybutów rastrowych (zwykle nie zawartych w innych formatach),
41 piramidy obrazów, metadane GDAL i statystyki wbudowane, zapewniając
42 także obsługę dużych plików z kompresją. Dzięki oparciu na standardzie
43 HDF5, zapewnia także podstawę, z której mogą wywodzić się inne
44 formaty; jest także dobrym wyborem do długoterminowej archiwizacji
45 danych. Udostępniono niezależną bibliotekę (libKEA), dającą pełny
46 dostęp do formatu obrazów KEA, a także sterownik GDA pozwalający na
47 używanie obrazów KEA w programach obsługujących GDAL.
48
49 %package devel
50 Summary:        Header files for LibKEA library
51 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LibKEA
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       hdf5-c++-devel
55 Requires:       libstdc++-devel
56
57 %description devel
58 Header files for LibKEA library.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe biblioteki LibKEA.
62
63 %package -n gdal-kea
64 Summary:        KEA plugin for GDAL library
65 Summary(pl.UTF-8):      Wtyczka KEA do biblioteki GDAL
66 Group:          Libraries
67 Requires:       %{name} = %{version}-%{release}
68 %if %{with gdal}
69 %requires_ge    gdal
70 %endif
71
72 %description -n gdal-kea
73 KEA plugin for GDAL library.
74
75 %description -n gdal-kea -l pl.UTF-8
76 Wtyczka KEA do biblioteki GDAL.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81 %patch1 -p1
82
83 %build
84 %cmake . \
85 %if %{with gdal}
86         -DGDAL_INCLUDE_DIR=%{_includedir}/gdal \
87         -DGDAL_LIB_PATH=%{_libdir} \
88 %endif
89         -DHDF5_INCLUDE_DIR=%{_includedir} \
90         -DHDF5_LIB_PATH=%{_libdir}
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %files
106 %defattr(644,root,root,755)
107 %doc README.md
108 %attr(755,root,root) %{_libdir}/libkea.so.*.*.*
109 %attr(755,root,root) %ghost %{_libdir}/libkea.so.1.4
110
111 %files devel
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_bindir}/kea-config
114 %attr(755,root,root) %{_libdir}/libkea.so
115 %{_includedir}/libkea
116
117 %if %{with gdal}
118 %files -n gdal-kea
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_libdir}/gdalplugins/gdal_KEA.so
121 %endif
This page took 0.100317 seconds and 3 git commands to generate.